Project

General

Profile

Actions

Bug #4068

closed

Upgrade from oi_148 fails due to "Unknown type (conditional) in depend action"

Added by Joseph Ellis almost 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Category:
PKG (Image Packaging System)
Target version:
-
Start date:
2013-08-21
Due date:
2014-02-06
% Done:

100%

Estimated time:
2.00 h
Difficulty:
Medium
Tags:
pkg

Description

Following the upgrade guide here http://wiki.openindiana.org/oi/Upgrading+OpenIndiana

sequence so far is as follows (as root):

  1. pkg unset-publisher opensolaris.org
Verified publisher as follows:
  1. pkg publisher
    PUBLISHER TYPE STATUS URI
    openindiana.org (preferred) origin online http://pkg.openindiana.org/dev/

#pkg refresh --full

#pkg image-update -nv

image update fails with

pkg: The requested operation cannot be completed due to invalid package metadata. Details follow:

invalid action in package pkg:,5.11-0.151.1.8:20130721T131442Z: depend fmri=library/python-2/tkinter-26 predicate=runtime/tk-8 type=conditional: Unknown type (conditional) in depend action

Seems similar to https://www.illumos.org/issues/2629

Have run through troubleshooting here, gotten nowhere: http://wiki.openindiana.org/oi/Troubleshooting+image-update+failures

Actions

Also available in: Atom PDF