Project

General

Profile

Actions

Bug #4074

closed

oi_151a8 - Can't login via gui at the console (in front of keyboard)

Added by John Sloan over 8 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
-
Start date:
2013-08-23
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

Just updated to OI from a7 to a8, after reboot at the console i tried to login as usual. Nice blue openindiana splash screen, username: typed it in, the nhit return and password: flashes up for a split second then disappears so only the blue background appears and the login button :(

I can still access the gui and login via VNC and can ssh terminal in as well.


Files

OI_151A8_NoPasswordBox.jpg (476 KB) OI_151A8_NoPasswordBox.jpg Screenshot of Login where no password box appears John Sloan, 2013-08-26 09:00 AM
Actions #1

Updated by Ken Mays over 8 years ago

  • Assignee set to OI JDS
Actions #2

Updated by Jon Tibble over 8 years ago

If you can log in via SSH look in your user's ~/.xsession-errors and see what's there after one of the failed logins.

I had an issue with script errors suggesting something extra is running now or something is more strict about what it runs. Fixing where the scripts loaded let me log in again.

Actions #3

Updated by John Sloan over 8 years ago

Hi Jon

Thank you so much for looking into this so quickly.
I am unable to login no matter which user I use.
Also strangely after opening the .xsession_errors file with nano when connected via putty, nano goes very strange, and when I do Ctrl-x to exit instead ^x appears in the text on screen and then I hit enter I can get out but if I try to load nano again I get- Sorry, Malloc not ready
I know its a separate issue which I'll log but just wondering if it has any relation.

I have attached a screen shot of the screen after i enter the username and hit return.

Here is a copy of my xsession_error file, i dont know what all this means so hopefully you'll understand it better.

/etc/gdm/Xsession: Beginning session setup...
/usr/bin/stat: cannot stat `/dev/audio': No such file or directory
/etc/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
GNOME_KEYRING_CONTROL=/var/tmp/keyring-MCod2G
GNOME_KEYRING_PID=1341
GNOME_KEYRING_CONTROL=/var/tmp/keyring-MCod2G
GNOME_KEYRING_CONTROL=/var/tmp/keyring-MCod2G
SSH_AUTH_SOCK=/var/tmp/keyring-MCod2G/ssh

  • (gnome-settings-daemon:1344): WARNING **: Call to screen_info_new is too frequent, skipping...
  • (gnome-settings-daemon:1344): WARNING **: Call to screen_info_new is too frequent, skipping...
  • (gnome-settings-daemon:1344): WARNING **: Call to screen_info_new is too frequent, skipping...
    /usr/bin/dispswitch exiting: too few (less than 2) or too many (more than 2) crtcs: 1
  • (nwam-manager:1350): WARNING **: nwam_walk_ncps Insufficient permissions for action
  • (nwam-manager:1350): WARNING **: nwam_walk_locs Insufficient permissions for action
  • (nwam-manager:1350): WARNING **: nwam_walk_enms Insufficient permissions for action
  • (nwam-manager:1350): WARNING **: nwam_walk_known_wlans unknown error
  • (gnome-settings-daemon:1344): WARNING **: Call to screen_info_new is too frequent, skipping...
    Initializing nautilus-open-terminal extension
    system-config-printer-applet: failed to start NewPrinterNotification service
  • Message: Initializing gksu extension...
  • (gnome-power-manager:1351): WARNING **: DBUS error: Could not get owner of name 'org.gnome.ScreenSaver': no such name
  • (gnome-power-manager:1351): DEBUG: proxy is NULL, maybe the daemon responsible for org.gnome.ScreenSaver is not running?
    Xlib: extension "DPMS" missing on display "::1:1.0".
  • (gnome-power-manager:1351): WARNING **: ERROR: Caller doesn't possess required privilege to change the governor: Syslog might give more information
  • (gnome-settings-daemon:1344): WARNING **: Call to screen_info_new is too frequent, skipping...
    glibtop: open (/proc/1436/cred): No such file or directory
    glibtop: open (/proc/1436/xmap): No such file or directory
    glibtop: open (/proc/1436/xmap): No such file or directory
    glibtop: open (/proc/1436/cred): No such file or directory
    glibtop: open (/proc/1436/xmap): No such file or directory
    glibtop: open (/proc/1436/xmap): No such file or directory
    glibtop: open (/proc/1436/cred): No such file or directory
    glibtop: open (/proc/1436/xmap): No such file or directory
    glibtop: open (/proc/1436/xmap): No such file or directory
  • (gnome-power-preferences:1669): WARNING **: DBUS error: Could not get owner of name 'org.gnome.ScreenSaver': no such name
  • (gnome-power-preferences:1669): DEBUG: proxy is NULL, maybe the daemon responsible for org.gnome.ScreenSaver is not running?

(gnome-power-preferences:1669): GModule-CRITICAL **: file gmodule.c: line 619: assertion `symbol_name != NULL' failed

(gnome-power-preferences:1669): libglade-WARNING **: could not find widget creation function

  • (gnome-power-manager:1351): WARNING **: ERROR: Caller doesn't possess required privilege to change the governor: Syslog might give more information
  • (gnome-power-preferences:1669): DEBUG: already disconnected from org.gnome.ScreenSaver
    Window manager warning: Fatal IO error 131 (Connection reset by peer) on display '::1:1.0'.
    gnome-settings-daemon: Fatal IO error 131 (Connection reset by peer) on X server ::1:1.0.
    The application 'nwam-manager' lost its connection to the display ::1:1.0;
    most likely the X server was shut down or you killed/destroyed
    the application.
Actions #4

Updated by Predrag Zečević about 8 years ago

Hi,

you can try with erasing of GNOME user preferences:

gnome-cleanup

check man page...
Maybe your setup has something very customized, which breaks login session.

Regards.

Actions #5

Updated by John Sloan about 8 years ago

Ok I've tried the clenup, to no avail, also I'm noticing now that Nautilus cannot open network locations, I've tried ssh etc, nothing. I'm getting the feeling my entire gnome install is completely busted.

Everything outside of gnome is fine, so my server is operational but this is very irritating, all was fine before update to 151 a8

I'm not aware of any complicated setup, just built from live CD when 151 a5

Actions #6

Updated by Milan Jurik about 8 years ago

  • Status changed from New to Feedback
  • Assignee changed from OI JDS to Milan Jurik
  • Priority changed from Urgent to Low

So after gnome-cleanup you are able to login, aren't you? What is "busted" on your setup today?

Actions #7

Updated by John Sloan about 8 years ago

Hi Milan,

You are absolutely correct. After running 'gnome-cleanup' for root as well as admin, I am now able to login to the console of the server (in front of keyboard).

I am truly greatful for your help.

What I mean by 'busted' is that other things on my gnome enviroment I have just noticed are not working anymore.

Nautilus for one, now it cannot handle any locations outside of the local machine so, ssh:// sftp:// ftp:// smb:// etc all fail with 'nautilus cannot handle xxx locations' or it trys to open /home/admin/ssh etc, or connect to server causes an error that says, 'Cannot connect to server you must provide a name for the server'

None of these errors occurred before the update.

I'm also finding that my zfs send recieve now keeps failing half way through with a broken pipe caused by mbuffer. also only since the update.

So I hope you can understand my frustration.

Actions #8

Updated by Milan Jurik about 8 years ago

  • Status changed from Feedback to Closed
  • Tags deleted (needs-triage)

John Sloan wrote:

Hi Milan,

You are absolutely correct. After running 'gnome-cleanup' for root as well as admin, I am now able to login to the console of the server (in front of keyboard).

Good to now. Gnome has problems with updates from time to time and cleanup is only safe way in such cases. Sorry.

I am truly greatful for your help.

What I mean by 'busted' is that other things on my gnome enviroment I have just noticed are not working anymore.

Nautilus for one, now it cannot handle any locations outside of the local machine so, ssh:// sftp:// ftp:// smb:// etc all fail with 'nautilus cannot handle xxx locations' or it trys to open /home/admin/ssh etc, or connect to server causes an error that says, 'Cannot connect to server you must provide a name for the server'

Are you speaking about 2 different issues or not? I know about https://www.illumos.org/issues/4058 and not about other ssh issues.

None of these errors occurred before the update.

I'm also finding that my zfs send recieve now keeps failing half way through with a broken pipe caused by mbuffer. also only since the update.

I am not sure how this is connected to Gnome.

So I hope you can understand my frustration.

Maybe but the key problem is that only one person (I) work on Gnome/JDS in OI and nobody was working on it for a year before me, so do not be surprised there are issues after the first bigger update of OI JDS from 2010.

Fill separate bugs for your issues if they are not documented yet. This one I am closing as closed after gnome-cleanup.

Actions #9

Updated by serum korea grosir kosmetik over 6 years ago

Karena banyaknya serum korea kw murah dan berdampak buruk pada wajah maka kami membuat perbedaan serum korea ori dan kw. Ciri-ciri Serum Korea ASLI dibawah ini mohon selalu dijadikan acuan dalam membeli Serum Korea karena ada banyak orang yang memalsukan atau membuat Serum Korea oplosan karena serum ini sangat berkhasiat dan laku dipasaran.

semoga dengan adanya artikel perbedaan antara serum korea asli dan palsu ini tidak ada lagi custumer yang tertipu oleh serum korea kw/tiruan. serum korea [[http://www.flickr.com/people/133449474@N04/]]

Actions

Also available in: Atom PDF