Project

General

Profile

Actions

Bug #410

closed

cannot find/execute 'sh' in ISA subdirectories

Added by sham pavman over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2010-11-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:
Gerrit CR:

Description

While building illumos on illumos I've hit this bug.

wrapster@osol:/code/illumos-gate/usr/src/cmd/sendmail/cf$ dmake
cd cf; pwd; /usr/ccs/bin/m4 -DSUN_HIDE_INTERNAL_DETAILS ../m4/cf.m4 sendmail.mc > sendmail.cf
/code/illumos-gate/usr/src/cmd/sendmail/cf/cf
sh: cannot find/execute "sh" in ISA subdirectories

/usr/ccs/bin/m4:../m4/cf.m4:../m4/cfhead.m4:27 can't open file
ifdef(SUN_HIDE_INTERNAL_DETAILS,,include(/tmp/cf109967))
*** Error code 1
dmake: Fatal error: Command failed for target `cf/sendmail.cf'
Current working directory /code/illumos-gate/usr/src/cmd/sendmail/cf

I've so far tried all manipulations to get 'sh' working but to no avail.
I tried changing PATH as well , still didnt work.

Actions #1

Updated by sham pavman over 10 years ago

looks like 'sh' is taken from /usr/xpg4/bin/i86 (truss helped me figure it out)
However the ARCH specific dir is absent under /usr/xpg4/bin/ so this needs to be investigated why ARCH is being used.

But for now to build illumos on illumos make sure your system has this

wrapster@osol:/code/illumos-gate/usr/src/cmd/sendmail/cf$ ls -l /usr/xpg4/bin/i86/sh
lrwxrwxrwx   1 root     root          11 Nov 11 22:38 /usr/xpg4/bin/i86/sh -> /usr/bin/sh

Actions #2

Updated by Garrett D'Amore over 10 years ago

  • Status changed from New to Rejected

This is not a bug ... unless you're using an older build of illumos with the xpg4 sh link problem. Any current version of illumos is free from this. Rejecting it.

Actions

Also available in: Atom PDF