Project

General

Profile

Actions

Bug #4104

closed

::spa_space no longer works

Added by Christopher Siden about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2013-09-04
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:
External Bug:

Description

Bug report by Matt Ahrens:

::spa_space fails with:
mdb: failed to read ms_allocmap from struct zfs`metaslab at ffffff02ce992e78:
only 392 of 416 bytes could be read

and then prints a bunch of garbage.  The problem is that the space_cb() was not
updated to know that type of metaslab_t::ms_map is now a pointer to a
space_map_t.

And this is why I should have switched everything to use mdb_ctf_vread() -- at
least we would have gotten a reasonable error message (something like
"incompatible type: expected space_map_t for member ms_map of struct
metaslab").

Actions

Also available in: Atom PDF