Project

General

Profile

Feature #4115

Transmission 2.60 upgrade

Added by r a over 7 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Category:
OI-Userland
Target version:
Start date:
2013-09-05
Due date:
2016-02-15
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Bite-size
Tags:
transmission

Description

The current version of Transmission is 1.93 from 2009, can the standard version be upgraded to a more modern 2013 release of 2.82 ?

#1

Updated by Ken Mays over 7 years ago

  • Category set to Desktop (JDS)
  • Assignee set to OI JDS
  • Estimated time set to 1.00 h
  • Difficulty changed from Medium to Bite-size
  • Tags changed from needs-triage to transmission

Ref: ,5.11-0.151.1.8:20130407T162720Z

#2

Updated by Nikola M. over 7 years ago

I am using Transmission 2.22 from SFE (Spec files extra IPS publisher, http://wiki.openindiana.org/oi/Spec+Files+Extra+Repository) for some time now and it works.
Yes it should be updated in main publisher.

From my experience with chasing transmission versions few years before on xubuntu, when changing to updated versions it often tend not to upgrade user transmittion setting in the right manner and most importantly not to transfer user RATIO right. (I lost it few times on Ubuntu)

So it needs to be tested for update from aether 1.93 or 2.22 that I suppose people are using till now.
Just a thought to say that, before someone just update transmission to newest version,
that every update should be tested with real data before pushing it, etc. (maybe not everyone makes zfs shapshots of home dir)

#3

Updated by Alex Viskovatoff over 7 years ago

  • Status changed from New to Feedback

SFEtransmission is now at 2.60. That is the latest version that does not require GTK+3. This version of Transmission works fine for me. The version that the SFE spec was at before, 2.33, worked fine, too.

Incidentally, upstream does not appear to be maintaining their spec.

#4

Updated by Ken Mays over 7 years ago

  • Due date set to 2013-12-11
  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

No, on Transmission >2.60. Based on the conclusion, Transmission 2.60 is the choice and Ian updated the SFE spec to v2.60. Either, Closing ticket, as we do have a newer version available than Transmission 1.93.

#5

Updated by Alex Viskovatoff over 5 years ago

  • Subject changed from Transmission 2.82 upgrade to Transmission 2.60 upgrade
  • Due date changed from 2013-12-11 to 2016-02-15
  • Category changed from Desktop (JDS) to OI-Userland
  • Status changed from Closed to In Progress
  • Assignee changed from OI JDS to Alexander Pyhalov
  • Priority changed from Low to Normal
  • Target version set to Hipster

I modified the userland Makefile to build the same version as the version of the SFE package that was referred to above, v2.60. It builds and appears to be stable, although I haven't tried leeching or seeding, since my local network is not configured for that.

Here is the link to the relevant commit at my github oi-userland repo:

https://github.com/herzen/oi-userland/commit/59c52880726ebdae03502c480b71d7b9a602097f

Since hipster has gtk3 now, the current version of Transmission can be built, but it crashes if you try to open a window. Thus, v2.60 is the highest OI can go right now without fixing that gtk3 problem. (Transmission v2.60 is the last version that can be built against gtk2.)

#6

Updated by Alexander Pyhalov over 5 years ago

  • Status changed from In Progress to Resolved

Merged your update to 2.60 (without gtk patch). Works for me.

Also available in: Atom PDF