Project

General

Profile

Actions

Bug #4126

closed

minor fixes to libkrb5 Makefile

Added by Andrew Stormont almost 9 years ago. Updated about 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2013-09-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

There are two mistakes in the libkrb5 Makefile:

1. Setting BUILD64 causes make to fail with a parser error.
2. INS.file should be used to install files.
3. The makefile should know how to create KRB5INCDIR.


Related issues

Related to illumos gate - Bug #11246: krb5 makefiles should use INS or INS.fileClosedRich Lowe

Actions
Is duplicate of illumos gate - Bug #1681: support for BUILD64=# no longer worksIn Progress2011-10-23

Actions
Is duplicate of illumos gate - Bug #4163: Illumos build should not break if /usr/bin/install is installedRejectedAndrew Stormont2013-09-30

Actions
Actions #1

Updated by Rich Lowe almost 9 years ago

The BUILD64 bug is everywhere. It'd be nice to fix it all in one pass.
(I actually have changes from a project to do this, if you wanted them)

Actions #2

Updated by Andrew Stormont almost 9 years ago

I prepared a patch for #1681 which fixes builds with BUILD64 set, but haven't bothered to upstream it because I'm still left with 64bit binaries in my proto area. If you've got a better patch I'd like to get my hands on it.

Actions #3

Updated by Andrew Stormont about 8 years ago

  • Status changed from New to Rejected

Closing. INS can be set. Not illumos problem.

Actions #4

Updated by Rich Lowe about 3 years ago

  • Related to Bug #11246: krb5 makefiles should use INS or INS.file added
Actions

Also available in: Atom PDF