Project

General

Profile

Bug #414

openjdk build

Added by Richard PALO almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
OpenIndiana Wiki
Target version:
-
Start date:
2010-11-12
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

Sorry, I haven't figured out how to add comments in the OpenIndiana WIKI as the keyword always fails...

How to get over the following in the build concerning (at least) jaxp?

I made sure that /source is in rpool avoiding a new filesystem...

I can go with Firefox to the jaxp site and download explicitly the zip file, but it doesn't seem to be in the same directory.

/usr/bin/mkdir -p /source/jdk7/build/solaris-i586/jaxp

######################################################################## ########################################################################
  1. Entering jaxp for target all ##### ########################################################################
    (cd ./jaxp/make && \
    gmake JDK_TOPDIR=/source/jdk7/jdk JDK_MAKE_SHARED_DIR=/source/jdk7/jdk/make/common/shared EXTERNALSANITYCONTROL=true SOURCE_LANGUAGE_VERSION=7 TARGET_CLASS_VERSION=7 MILESTONE=internal BUILD_NUMBER=b00 JDK_BUILD_NUMBER=b00 FULL_VERSION=1.7.0-internal-richard_2010_11_13_08_06-b00 PREVIOUS_JDK_VERSION=1.6.0 JDK_VERSION=1.7.0 JDK_MKTG_VERSION=7 JDK_MAJOR_VERSION=1 JDK_MINOR_VERSION=7 JDK_MICRO_VERSION=0 PREVIOUS_MAJOR_VERSION=1 PREVIOUS_MINOR_VERSION=6 PREVIOUS_MICRO_VERSION=0 ARCH_DATA_MODEL=32 COOKED_BUILD_NUMBER=0 ALT_OUTPUTDIR=/source/jdk7/build/solaris-i586/jaxp ALT_BOOTDIR=/usr/java ALT_JDK_IMPORT_PATH=/usr/java ALT_LANGTOOLS_DIST=/source/jdk7/build/solaris-i586/langtools/dist all)
    gmake2: Entering directory `/source/jdk7/jaxp/make'
    cd .. && JAVA_HOME=/usr/java ant -Djavac.target=7 -Djavac.source=7 -Dallow.downloads=true -Ddrops.dir=/java/devtools/share/jdk7-drops -Doutput.dir=/source/jdk7/build/solaris-i586/jaxp -Djdk.home=/usr/java -Dbootstrap.dir=/source/jdk7/build/solaris-i586/langtools/dist/bootstrap -version
    Apache Ant version 1.7.1 compiled on February 16 2010
    cd .. && JAVA_HOME=/usr/java ant -Djavac.target=7 -Djavac.source=7 -Dallow.downloads=true -Ddrops.dir=/java/devtools/share/jdk7-drops -Doutput.dir=/source/jdk7/build/solaris-i586/jaxp -Djdk.home=/usr/java -Dbootstrap.dir=/source/jdk7/build/solaris-i586/langtools/dist/bootstrap all
    Buildfile: build.xml
    [mkdir] Created dir: /source/jdk7/build/solaris-i586/jaxp/build/xml_generated
    [copy] Copying 1 file to /source/jdk7/build/solaris-i586/jaxp/build/xml_generated

banner:
[echo] --------------------------------------

[echo] + Starting ant project jaxp
[echo] +-------------------------------------

-javac-jar-exists:

sanity:
[echo] Sanity Settings:
[echo] ant.home=/usr
[echo] ant.version=Apache Ant version 1.7.1 compiled on February 16 2010
[echo] ant.java.version=1.6
[echo] java.home=/usr/jdk/instances/jdk1.6.0/jre1.6.0_21
[echo] java.version=1.6.0_21
[echo] os.name=SunOS
[echo] os.arch=x86
[echo] os.version=5.11
[echo] bootstrap.dir=/source/jdk7/build/solaris-i586/langtools/dist/bootstrap
[echo] javac.jar=/source/jdk7/build/solaris-i586/langtools/dist/bootstrap/lib/javac.jar
[echo] javac.memoryInitialSize=256m
[echo] javac.memoryMaximumSize=512m
[echo] javac.source=7
[echo] javac.debug=true
[echo] javac.target=7
[echo] javac.version.opt=
[echo] javac.lint.opts=
[echo] javac.no.jdk.warnings=-XDignore.symbol.file=true
[echo] output.dir=/source/jdk7/build/solaris-i586/jaxp
[echo] build.dir=/source/jdk7/build/solaris-i586/jaxp/build
[echo] dist.dir=/source/jdk7/build/solaris-i586/jaxp/dist
[echo] drop.dir=${drop.dir}
[echo] drops.dir=/java/devtools/share/jdk7-drops

init:
[mkdir] Created dir: /source/jdk7/build/solaris-i586/jaxp/build/classes
[mkdir] Created dir: /source/jdk7/build/solaris-i586/jaxp/dist
[mkdir] Created dir: /source/jdk7/build/solaris-i586/jaxp/dist/lib

-jaxp_src-ready:

-jaxp_src-copy-bundle:

-jaxp_src-url-should-be-used:

-jaxp_src-url-bundle:
[echo] Downloading from https://jaxp.dev.java.net/files/documents/913/152561/jaxp-1_4_4.zip
[mkdir] Created dir: /source/jdk7/build/solaris-i586/jaxp/drop/bundles
[get] Getting: https://jaxp.dev.java.net/files/documents/913/152561/jaxp-1_4_4.zip
[get] To: /source/jdk7/build/solaris-i586/jaxp/drop/bundles/jaxp-1_4_4.zip.temp
[get] Error getting https://jaxp.dev.java.net/files/documents/913/152561/jaxp-1_4_4.zip to /source/jdk7/build/solaris-i586/jaxp/drop/bundles/jaxp-1_4_4.zip.temp

BUILD FAILED
javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No subject alternative DNS name matching jaxp.dev.java.net found.
at com.sun.net.ssl.internal.ssl.Alerts.getSSLException(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.fatal(Unknown Source)
at com.sun.net.ssl.internal.ssl.Handshaker.fatalSE(Unknown Source)
at com.sun.net.ssl.internal.ssl.Handshaker.fatalSE(Unknown Source)
at com.sun.net.ssl.internal.ssl.ClientHandshaker.serverCertificate(Unknown Source)
at com.sun.net.ssl.internal.ssl.ClientHandshaker.processMessage(Unknown Source)
at com.sun.net.ssl.internal.ssl.Handshaker.processLoop(Unknown Source)
at com.sun.net.ssl.internal.ssl.Handshaker.process_record(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHandshake(Unknown Source)
at sun.net.www.protocol.https.HttpsClient.afterConnect(Unknown Source)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(Unknown Source)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(Unknown Source)
at org.apache.tools.ant.taskdefs.Get.doGet(Get.java:145)
at org.apache.tools.ant.taskdefs.Get.execute(Get.java:78)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:357)
at org.apache.tools.ant.Target.performTasks(Target.java:385)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
at org.apache.tools.ant.Main.runBuild(Main.java:758)
at org.apache.tools.ant.Main.startAnt(Main.java:217)
at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
Caused by: java.security.cert.CertificateException: No subject alternative DNS name matching jaxp.dev.java.net found.
at sun.security.util.HostnameChecker.matchDNS(Unknown Source)
at sun.security.util.HostnameChecker.match(Unknown Source)
at com.sun.net.ssl.internal.ssl.X509TrustManagerImpl.checkIdentity(Unknown Source)
at com.sun.net.ssl.internal.ssl.X509TrustManagerImpl.checkServerTrusted(Unknown Source)
... 29 more

Total time: 3 seconds
gmake2: * [all] Error 1
gmake2: Leaving directory `/source/jdk7/jaxp/make'
gmake1:
[jaxp-build] Error 2
gmake1: Leaving directory `/source/jdk7'
gmake: *
* [build_product_image] Error 2
richard@shuttleX:/source/jdk7$

History

#1

Updated by Richard PALO almost 9 years ago

Update: apparently there is recently a bit of flux in the java.net websites.

I was finally able to build (after a clobber) by downloading the following three files:
jaxp-1_4_4.zip jdk7-jaxws2_2-2010_08_19.zip
jdk7-jaf-2010_08_19.zip
from the JAXP and JAXWS projects...

and modifying build.sh by adding ALT_DROPS_DIR=~/packages/SOURCES in my case.

BTW, I had better luck by putting the sunstudio12u1 path in the front rather than the end of the PATH line.

The following is what seemed to work best for me:
#!/bin/bash
unset CLASSPATH
unset JAVA_HOME
env -i PATH=/opt/sunstudio12.1/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/ccs/bin:/usr/gnu/bin \
LANG=C \
gmake \
ALT_BOOTDIR=/usr/java \
ALT_JDK_IMPORT_PATH=/usr/java \
ALT_CUPS_HEADERS_PATH=/usr/include \
ALT_DROPS_DIR=~/packages/SOURCES \
ALLOW_DOWNLOADS=true \
NO_DOCS=true \
ALT_COMPILER_PATH=/opt/sunstudio12.1/bin \
HOTSPOT_BUILD_JOBS=1

#2

Updated by Julian Wiesener over 8 years ago

  • Status changed from New to Closed

Not a Bug.

Contact us via Mail (new-developers) or in IRC (#oi-dev) if you like to have an wiki account

Also available in: Atom PDF