Project

General

Profile

Actions

Bug #4177

closed

hipster: vim segfault in stop_insert+0x42()

Added by Marcel Telka over 10 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2013-10-04
Due date:
2013-12-04
% Done:

100%

Estimated time:
8.00 h
Difficulty:
Medium
Tags:
vim

Description

vim (version 7.4) segfaulted recently on hipster (version from 2013-09-01):

> ::status
debugging core file of vim (32-bit) from telcontar
file: /usr/bin/vim
initial argv: vim raven-oi
threading model: native threads
status: process terminated by SIGSEGV (Segmentation Fault), pid=18016 uid=101
> ::stack
libc.so.1`kill+0x15(1, 0, 82ca170, 828c901, b, 828c9c0)
preserve_exit+0xb8(82ca170, 8287c81, 828c9c0, feeef744, fef788c0, 0)
deathtrap+0x120(b, 0, 82c914c, fef74000, fedb2a40, fef74000)
libc.so.1`__sighndlr+0x15(b, 0, 82c914c, 81a08d0, 0, 0)
libc.so.1`call_user_handler+0x292(b, 0, 82c914c, 0, 0, 0)
libc.so.1`sigacthandler+0x77(b, 0, 82c914c)
libc.so.1`strlen+0x30(0, 8283fa8, 1, 8120cae, 0, 0)
stop_insert+0x42(8283fa8, 61, 0, 11, 0, 0)
ins_esc+0xbe(1b, 1, 82cd400, 0, 82cd400, 0)
edit+0x483(61, 0, 0, 0, 1, 1)
nv_edit.part.35+0xf8(80477c0, 1, 0, 0, 61, 7fffffff)
normal_cmd+0xc52(8047850, 1, 0, 0, 0, 0)
main_loop+0x35b(0, 0, 82cd400, 0, 82cd400, fefce995)
main+0x126f(2, 8047a14, 8047a20, 8047a08, 807fc72, 826c480)
_start+0x83(2, 8047b28, 8047b2c, 0, 8047b35, 8047b5b)
>

The core file is available here: http://telka.sk/illumos/4177/core.vim.101.1380693363

Actions #1

Updated by Alexander Pyhalov over 10 years ago

Is this panic reproducable? I'm asking because with my vim with this core file shows another back trace:

(gdb) bt
#0 0xfef05205 in kill () from /lib/libc.so.1
#1 0x081a2405 in mch_exit ()
#2 0x0815feb8 in preserve_exit ()
#3 0x081a09f0 in ?? ()
#4 0x082ca170 in ?? ()
#5 0x08287c81 in ?? ()
#6 0x0828c9c0 in ?? ()
#7 0xfeeef744 in rw_unlock () from /lib/libc.so.1
#8 0xfef00e05 in __sighndlr () from /lib/libc.so.1
#9 0xfeef5833 in call_user_handler () from /lib/libc.so.1
#10 <signal handler called>
#11 0xfee71950 in strlen () from /lib/libc.so.1
#12 0x0811ad63 in get_inserted ()
#13 0x080974b2 in ?? ()
#14 0x00000000 in ?? ()

Actions #2

Updated by Marcel Telka over 10 years ago

Sorry, no idea how to reproduce it.
Try mdb to see the right stack.

Actions #3

Updated by Ken Mays over 10 years ago

  • Assignee changed from OI SFW to OI Userland
  • Tags changed from needs-triage to vim
Actions #4

Updated by Ken Mays about 10 years ago

  • Due date set to 2013-12-04
  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Estimated time set to 8.00 h

Tested & resolved. I can't reproduce the problem with the current hipster release based on current info given.

Actions #5

Updated by Marcel Telka about 10 years ago

  • Status changed from Closed to In Progress
  • % Done changed from 100 to 0

Yes, it is hardly reproducible, but this does not mean it is fixed, so reopening.

Actions #6

Updated by Anonymous about 10 years ago

Possible we could bump to Vim 7.4.169 or later, but did this issue happen on the same machine with the previous Vim 7.3.x build??

Actions #7

Updated by Ken Mays about 10 years ago

  • Assignee changed from OI Userland to Marcel Telka
Actions #8

Updated by Ken Mays over 9 years ago

  • Status changed from In Progress to Closed
  • Assignee changed from Marcel Telka to OI Userland
  • % Done changed from 0 to 100

Issues resolved in 32-bit dependencies. Since bug is 'very hard to replicate' - closing ticket until a 'repeatable test can be provided' to reproduce the specific issue during OI dev testing.

Actions

Also available in: Atom PDF