Project

General

Profile

Bug #4205

wnck-applet segfault at wncklet_connect_while_alive+0x37

Added by Marcel Telka almost 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Desktop (JDS)
Target version:
-
Start date:
2013-10-14
Due date:
2014-02-14
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
jds

Description

I just found that wnck-applet segfaulted recently with this stack:

> ::status                            
debugging core file of wnck-applet (32-bit) from telcontar
file: /usr/lib/wnck-applet
initial argv: /usr/lib/wnck-applet --oaf-activate-iid=OAFIID:GNOME_Wncklet_Factory --oaf-ior-
threading model: native threads
status: process terminated by SIGSEGV (Segmentation Fault), addr=0
> ::stack
wncklet_connect_while_alive+0x37(0, 805cb30, 805974c, 816f668, 82409d8)
display_properties_dialog+0x539(8151230, 816f668, 817a268, fdd97822)
libbonoboui-2.so.0.0.0`marshal_VOID__USER_DATA_STRING+0x7b(817b5a8, 8046940, 2, 816a180, 0, 0)
libgobject-2.0.so.0.2800.6`g_closure_invoke+0xe1(817b5a8, 8046940, 2, 816a180, 0, 8046890)
libbonobo-2.so.0.0.0`bonobo_closure_invoke_va_list+0x320(817b5a8, 8046940, 8046a08, fde67ef9)
libbonobo-2.so.0.0.0`bonobo_closure_invoke+0x456(817b5a8, 4, 80ebeb0, 8151230, 40, 8241da0)
libbonoboui-2.so.0.0.0`impl_Bonobo_UIComponent_execVerb+0x83(8151244, 8241da0, 8046b20, fde969f4, 4, fe26e8cc)
libbonobo-2.so.0.0.0`_ORBIT_skel_small_Bonobo_UIComponent_execVerb+0x16(8151244, 0, 8046aec, 0, 8046b20, fdd976b4)
libORBit-2.so.0.1.0`ORBit_c_stub_invoke+0xa1(81705d0, fde969f4, 4, 0, 8046aec, 0)
libbonobo-2.so.0.0.0`Bonobo_UIComponent_execVerb+0x4b(81705d0, 8241da0, 8046b20, fdd9d7d0)
libbonoboui-2.so.0.0.0`real_exec_verb+0x15e(814f180, 8152258, 817b7e8, fdd9d99a)
libbonoboui-2.so.0.0.0`impl_emit_verb_on+0x10f(814f180, 8160000, 80f2d68, fec8b4da)
libgobject-2.0.so.0.2800.6`g_cclosure_marshal_VOID__POINTER+0x63(80f59e8, 0, 2, 81ec228, 8046d48, fdd9d98c)
libgobject-2.0.so.0.2800.6`g_type_class_meta_marshal+0x46(80f59e8, 0, 2, 81ec228, 8046d48, 4c)
libgobject-2.0.so.0.2800.6`g_closure_invoke+0xe1(80f59e8, 0, 2, 81ec228, 8046d48, 814f180)
libgobject-2.0.so.0.2800.6`signal_emit_unlocked_R+0x111d(80f5600, 0, 814f180, 0, 81ec228, 814f180)
libgobject-2.0.so.0.2800.6`g_signal_emit_valist+0x94e(814f180, bb, 0, 8046f0c)
libgobject-2.0.so.0.2800.6`g_signal_emit+0x25(814f180, bb, 0, 8160000)
libbonoboui-2.so.0.0.0`bonobo_ui_engine_emit_verb_on_w+0x3d(814f180, 80f2510, 8046f38, fdda4b00)
libbonoboui-2.so.0.0.0`exec_verb_cb+0x30(80f2510, 814f180, 8046f78, fec8ab82)
libgobject-2.0.so.0.2800.6`g_cclosure_marshal_VOID__VOID+0x5d(8241f60, 0, 1, 81605b0, 80470b8, 0)
libgobject-2.0.so.0.2800.6`g_closure_invoke+0xe1(8241f60, 0, 1, 81605b0, 80470b8, 1)
libgobject-2.0.so.0.2800.6`signal_emit_unlocked_R+0x9b6(80c8da0, 0, 80f2510, 0, 81605b0, 80f2510)
libgobject-2.0.so.0.2800.6`g_signal_emit_valist+0x94e(80f2510, 5e, 0, 804727c)
libgobject-2.0.so.0.2800.6`g_signal_emit+0x25(80f2510, 5e, 0, feabf1c4)
libgtk-x11-2.0.so.0.2000.1`gtk_widget_activate+0x49(80f2510, 8234030, 80472c8, fe9a5faa)
libgtk-x11-2.0.so.0.2000.1`gtk_menu_shell_activate_item+0xe6(8234030, 80f2510, 1, fe9a52b1)
libgtk-x11-2.0.so.0.2000.1`gtk_menu_shell_button_release+0x20c(8234030, 81baf80, 8047348, fe99b7d8)
libgtk-x11-2.0.so.0.2000.1`gtk_menu_button_release+0xed(8234030, 81baf80)
libgtk-x11-2.0.so.0.2000.1`_gtk_marshal_BOOLEAN__BOXED+0x74(8098f20, 80474e0, 2, 81ebf18, 8047508, fe99b75c)
libgobject-2.0.so.0.2800.6`g_type_class_meta_marshal+0x46(8098f20, 80474e0, 2, 81ebf18, 8047508, b4)
libgobject-2.0.so.0.2800.6`g_closure_invoke+0xe1(8098f20, 80474e0, 2, 81ebf18, 8047508, fecb1630)
libgobject-2.0.so.0.2800.6`signal_emit_unlocked_R+0x111d(80970d0, 0, 8234030, 8047620, 81ebf18, 14)
libgobject-2.0.so.0.2800.6`g_signal_emit_valist+0x741(8234030, 22, 0, 80476cc)
libgobject-2.0.so.0.2800.6`g_signal_emit+0x25(8234030, 22, 0, 81baf80, 80476ec, fecb0e2c)
libgtk-x11-2.0.so.0.2000.1`gtk_widget_event_internal+0x204(8234030, 81baf80, 8047738, feabeb86)
libgtk-x11-2.0.so.0.2000.1`gtk_widget_event+0xb4(8234030, 81baf80, 8047778, fe991a29)
libgtk-x11-2.0.so.0.2000.1`gtk_propagate_event+0x11a(80f2510, 81baf80, 1, fe99068e)
libgtk-x11-2.0.so.0.2000.1`gtk_main_do_event+0x26a(81baf80, 0, 80477f8, fe7b082a)
libgdk-x11-2.0.so.0.2000.1`gdk_event_dispatch+0x5a(8095270, 0, 0, fed319ee)
libglib-2.0.so.0.2800.6`g_main_dispatch+0x1df(80952b8, fee01a7c, 80478f8, fed32f9a)
libglib-2.0.so.0.2800.6`g_main_context_dispatch+0x93(80952b8, 0, 8167d40, c)
libglib-2.0.so.0.2800.6`g_main_context_iterate+0x3a8(80952b8, 1, 1, 806fcd0)
libglib-2.0.so.0.2800.6`g_main_loop_run+0x1d8(80e2e88, 80e2e88, 8047978, fde54fd2)
libbonobo-2.so.0.0.0`bonobo_main+0x64(80479a0, fefc3330, fdea0118, b, fde5337e, fefeff78)
libbonobo-2.so.0.0.0`bonobo_generic_factory_main_timeout+0xb1(80de410, fdde9384, 80ddf88, 7d0)
libbonobo-2.so.0.0.0`bonobo_generic_factory_main+0x26(80de410)
libpanel-applet-2.so.0.2.67`panel_applet_factory_main_closure+0xf7(805b760, 80de380, 809c178, fdde95bd)
libpanel-applet-2.so.0.2.67`panel_applet_factory_main+0x3d(805b760)
main+0xfc(1, 8047a84, 8047a94, 805600f)
_start+0x7d(3, 8047b90, 0, 0, 0, 8047be5)
>

It was with hipster from 2013-10-09.

The core file is at http://telka.sk/illumos/4205/core.wnck-applet.101.1381429258

History

#1

Updated by Ken Mays over 6 years ago

  • Tags changed from needs-triage to jds
  • Estimated time set to 1.00 h
  • % Done changed from 0 to 100
  • Status changed from New to Closed
  • Due date set to 2014-02-14

Tested for hipster 01/2014. Can't reproduce at this time.
Src: http://hg.opensolaris.cz/oi-jds/file/91630ebbcfcc

Also available in: Atom PDF