Project

General

Profile

Bug #4207

history_008_pos depends on obsolete internal history log message

Added by Christopher Siden almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2013-10-14
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

With the changes I'm working on, tests/functional/history/history_008_pos
fails:

stdout| 03:33:30 NOTE: Didn't find hold on testpool.8423/testfs.8423@snap with
tag
stderr| 
stdout| 03:33:30 ERROR: verify_hold zfs hold -r tag
testpool.8423/testfs.8423@snap hold -i exited 1

The problem is that I updated the internal log message.  Before it included
"tag = <tag>", which the test is looking for.  With my changes, it will have
"tag=<tag>" (note lack of spaces), which is more consistent with the other
history messages (e.g. for "zfs release").

History

#1

Updated by Christopher Siden over 5 years ago

  • Status changed from In Progress to Closed
commit f38cb554a534c6df738be3f4d23327e69888e634
Author: John Wren Kennedy <john.kennedy@delphix.com>
Date:   Tue Dec 10 11:09:51 2013

    4206 history_003_pos relies on exact size of history log and entries
    4207 history_008_pos depends on obsolete internal history log message
    4208 Typo in zfs_main.c: "posxiuser" 
    4209 Populate zfstest with the remainder of the STF tests
    Reviewed by: Sonu Pillai <sonu.pillai@delphix.com>
    Reviewed by: Will Guyette <will.guyette@delphix.com>
    Reviewed by: Eric Diven <eric.diven@delphix.com>
    Reviewed by: Christopher Siden <christopher.siden@delphix.com>
    Approved by: Richard Lowe <richlowe@richlowe.net>

Also available in: Atom PDF