Project

General

Profile

Bug #4231

mutt segfault at index_color+0x80()

Added by Marcel Telka almost 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2013-10-18
Due date:
2013-12-04
% Done:

0%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
mutt

Description

> ::status
debugging core file of mutt (32-bit) from telcontar
file: /usr/bin/mutt
initial argv: mutt
threading model: native threads
status: process terminated by SIGSEGV (Segmentation Fault), addr=10
> ::stack
index_color+0x80(83, 0, 0, fea1231e, 80463c0, 0)
menu_redraw_motion+0x153(81fe3d0, 804686c, 0, 81d41a0, 81fe3e4, 0)
mutt_index_menu+0x9c8(80472f0, 0, 0, 8118f51, fec90578, fefa0c08)
main+0xf2f(1, 8047a3c, 8047a44, 8113e20, 0, 0)
_start+0x83(1, 8047b48, 0, 8047b4d, 8047b73, 8047b86)
>

This is with hipster from 2013-10-16 (Mutt 1.5.21).


Related issues

Related to OpenIndiana Distribution - Bug #4482: mutt segfault at imap_fetch_message+0x6af()Closed2014-01-152014-01-31

Actions

History

#2

Updated by Ken Mays almost 7 years ago

  • Due date set to 2013-12-04
  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
  • Tags changed from needs-triage to mutt

Reported as 'possibly' fixed in: http://bugs.mutt.org/trac/ticket/3143

#3

Updated by Marcel Telka over 6 years ago

  • Status changed from Closed to In Progress

This is not fixed. Reopening.

It is true that mutt has been updated from 1.5.21 to 1.5.22, but there is nothing in the 1.5.22 sources that would prevent this bug to appear again. And since the bug is not easily reproducible, there is no reason to have this bug closed.

#4

Updated by Marcel Telka over 6 years ago

  • % Done changed from 100 to 0
#5

Updated by Ken Mays about 6 years ago

  • Status changed from In Progress to Closed
  • Assignee changed from Marcel Telka to Ken Mays

I'm taking over this ticket (pushing to mutt 1.5.23). One main thing if you'd like to reopen this ticket: consult the mutt developers and have them repeat or confirm they can reproduce the bug themselves in Mutt 1.5.23 (what I'm committing in oi-userland. This bug was open for TEN months and NO patches or mutt-developer confirmation other than ((possibly) fixed) exists in their current bug reports). Also, you should provide a test procedure on how to reproduce the bug to oi-userland so it can be worked on or retested. Without those critical pieces of data, we can only do so much...

#6

Updated by Marcel Telka almost 4 years ago

Happened again with mutt 1.7.1:

> ::status
debugging core file of mutt (32-bit) from telcontar
file: /usr/bin/mutt
initial argv: mutt -F .muttrc-telka.sk
threading model: native threads
status: process terminated by SIGSEGV (Segmentation Fault), addr=10
> ::stack
index_color+0x70(3be, 22, 0, 80a7cf3, 53454d5f, 45474153)
menu_redraw_motion.part.4+0x29(8373d88, 80467ec, 8047108, 8082c2d, 28, fef6f000)
mutt_index_menu+0x8f1(1, fede0510, 14, 0, 0, 0)
main+0x1a5b(804794c, fef796e8, 8047988, 8067eb3, 3, 8047994)
_start+0x83(3, 8047ab8, 8047abd, 8047ac0, 0, 8047ad1)
>

Also available in: Atom PDF