Project

General

Profile

Bug #4269

Need to bump packet version in libraries introducing new symbol versions

Added by Alexander Pyhalov almost 7 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
OI-Userland
Target version:
-
Start date:
2013-10-24
Due date:
2013-12-25
% Done:

0%

Estimated time:
4.00 h
Difficulty:
Medium
Tags:
oi-build

Description

Currently system components has 0.5.11-0.151.1.8.1 version. This leads to the following error:
when new version of library symbols appear (e.g., ILLUMOS_0.6), all newly compiled software binds by default to these versions of symbols. But old systems don't have this version of symbols in the library. So, they can't use newly compiled binaries. But we cannot distinguish two versions of library by version number. So, after installation software can fall with something like:
ld.so.1: php: fatal: libc.so.1: version 'ILLUMOS_0.6' not found (required by file /usr/php/5.4/bin/php).

History

#1

Updated by Ken Mays almost 7 years ago

  • Due date set to 2013-12-25
  • Category set to 35
  • Assignee set to Andrzej Szeszo
  • Estimated time set to 4.00 h
  • Tags changed from needs-triage to oi-build
#2

Updated by Aurélien Larcher over 4 years ago

  • Category changed from 35 to OI-Userland
#3

Updated by Alexander Pyhalov over 4 years ago

  • Status changed from New to Resolved

The issue was resolved long ago when we moved to the current versioning sheme

Also available in: Atom PDF