Project

General

Profile

Actions

Bug #4295

closed

libshare sa_get_proto_status sometimes returns unallocated strings

Added by Robert Mustacchi almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
lib - userland libraries
Start date:
2013-11-07
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

The libshare sa_get_proto_status op expects to have been returned an allocated string from memory that it has to free. When autofs and smb are unable to determine their status from SMF, say the service isn't installed, then they return the string "-". Unfortunately this is a constant string and not a duplicate of it which means that when sharectl consumes libshare and tries to free it, we understandably abort due to trying to free a constant string.

Actions #1

Updated by Robert Mustacchi almost 8 years ago

  • Status changed from New to Resolved

Resolved in 652601fb657e961ff66dadcd87ddfc146c5db0ca.

Actions

Also available in: Atom PDF