Project

General

Profile

Actions

Bug #4336

closed

Cannot raise the file descriptor limit over 64K for a project under SMF

Added by Robert Mustacchi almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
lib - userland libraries
Start date:
2013-11-17
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

A customer hit a case where under SMF they were unable to use a project to increase the file descriptor limit to over 64k. Upon investigation, Jerry had the following comment:

I have found the bug in usr/src/lib/libproject/common/setproject.c in the rctl_set() function. I have tested the fix and Robert is reviewing it. The problem is that we see the existing rctls and set teardown_basic and teardown_priv to indicate that we want to remove those existing rctls, but in the loop to remove them, the logic to delete the rctl is incorrect, so it only deletes the first one it sees, then fails to find the subsequent rctls.

Actions #1

Updated by Robert Mustacchi over 7 years ago

  • Status changed from New to Resolved

Resolved in 96ab4d5390a62b7e1743ec1fad5c0eef9682b961.

Actions

Also available in: Atom PDF