Project

General

Profile

Bug #4348

Assertion failed: rn->rn_nozpool == B_FALSE, file ../common/libzfs_import.c, line 1080, function zpool_open_func

Added by Igor Kozhukhov almost 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2013-11-23
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

i have mirror zpool created with 2 SATA drives on SATA controller.

root@srv249:~# format
Searching for disks...done

AVAILABLE DISK SELECTIONS:
       0. c16t0d0 <ATA-WDC WD20EARS-00M-AB51-1.82TB>
          /pci@0,0/pci1043,82d4@1f,2/disk@0,0
       1. c16t1d0 <ATA-WDC WD20EARS-00M-AB51-1.82TB>
          /pci@0,0/pci1043,82d4@1f,2/disk@1,0

root@srv249:~# zpool status
  pool: data3
 state: ONLINE
  scan: scrub repaired 0 in 17h18m with 0 errors on Tue Jul 17 21:17:47 2012
config:

        NAME         STATE     READ WRITE CKSUM
        data3        ONLINE       0     0     0
          mirror-0   ONLINE       0     0     0
            c16t1d0  ONLINE       0     0     0
            c16t0d0  ONLINE       0     0     0

i have connected 2 SATA drives to LSISA911-8i card and have configuration:

       2. c18t50014EE25B2CD5FBd0 <ATA-WDC WD20EARS-00M-AB51-1.82TB>
          /scsi_vhci/disk@g50014ee25b2cd5fb
       3. c18t50014EE205D7AD85d0 <ATA-WDC WD20EARS-00M-AB51-1.82TB>
          /scsi_vhci/disk@g50014ee205d7ad85

i tried to import zpool and i got a message:

root@srv249:/etc/apt# zpool import data3
Assertion failed: rn->rn_nozpool == B_FALSE, file ../common/libzfs_import.c, line 1080, function zpool_open_func
Abort (core dumped)

core file:

root@srv249:~# mdb core
Loading modules: [ libumem.so.1 libc.so.1 libtopo.so.1 libavl.so.1 libnvpair.so.1 libuutil.so.1 ld.so.1 ]
> $C
fe273be8 libc.so.1`_lwp_kill+7(8, 6, fe273c18, fef45000, fef45000, fe273c80)
fe273c08 libc.so.1`raise+0x2b(6, 0, fe273c20, fee9a254, 0, 0)
fe273c58 libc.so.1`abort+0x10e(fe273c80, fe273c80, 71, fede9bcb, fede9b02, 438)
fe273e88 0xfee4c52b(fede9bcb, fede9b02, 438, fede7d89, fef4b7c0, fe773240)
fe273f58 libzfs.so.1`zpool_open_func+0x161(809bc10, c, fe273fc8, fe273f98, fef4bac0, 809bc10)
fe273fc8 libc.so.1`tpool_worker+0x193(fed90880, 0, 0, 0, 0, 0)
fe273fe8 libc.so.1`_thrp_setup+0x86(fe773240)
fe273ff8 libc.so.1`_lwp_start(fe773240, 0, 0, 0, 0, 0)


Related issues

Is duplicate of illumos gate - Bug #1778: Assertion failed: rn->rn_nozpool == B_FALSE, file ../common/libzfs_import.c, line 1077, function zpool_open_funcClosed2011-11-15

Actions

History

#1

Updated by Andrew Stormont over 4 years ago

  • Is duplicate of Bug #1778: Assertion failed: rn->rn_nozpool == B_FALSE, file ../common/libzfs_import.c, line 1077, function zpool_open_func added
#2

Updated by Electric Monk over 4 years ago

  • Status changed from New to Closed

git commit bd0f709169e67f4bd34526e186a7c34f595f0d9b

commit  bd0f709169e67f4bd34526e186a7c34f595f0d9b
Author: Andrew Stormont <andyjstormont@gmail.com>
Date:   2015-05-29T15:10:20.000Z

    1778 Assertion failed: rn->rn_nozpool == B_FALSE, file ../common/libzfs_import.c, line 1077, function zpool_open_func
    Reviewed by: Matthew Ahrens <mahrens@delphix.com>
    Reviewed by: George Wilson <george@delphix.com>
    Reviewed by: Richard Elling <richard.elling@richardelling.com>
    Approved by: Gordon Ross <gordon.ross@nexenta.com>

Also available in: Atom PDF