Project

General

Profile

Bug #4358

syslog(3c) man page refers non-existent printf(3ucb)

Added by Marcel Telka over 6 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
manpage - manual pages
Start date:
2013-11-25
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

The syslog(3c) man page refers non-existent printf(3ucb) man page here:

     The message body is generated from the message and following
     arguments  in  the same manner as if these were arguments to
     printf(3UCB), except that occurrences of %m  in  the  format
     string  pointed  to  by the message argument are replaced by
     the error message string associated with the  current  value
     of errno.  A trailing NEWLINE character is added if needed.

and here:

SEE ALSO
     at(1), crontab(1), logger(1),  login(1),  lpc(1B),  lpr(1B),
     auditd(1M),   cron(1M),   getty(1M),   in.ftpd(1M),  su(1M),
     syslogd(1M),  printf(3UCB),  syslog.conf(4),  attributes(5),
     standards(5)

Related issues

Is duplicate of illumos gate - Bug #8212: manpages contain obsolete referencesClosed2017-05-13

Actions

History

#1

Updated by Marcel Telka over 6 years ago

I think the problem is that we are missing the 3ucb man pages (Solaris 10 have such man pages). I also found that some other 3ucb man pages are referenced across our man pages, for example lastcomm(1) references sigvec(3UCB).

#2

Updated by Peter Tribble almost 2 years ago

  • Is duplicate of Bug #8212: manpages contain obsolete references added
#3

Updated by Peter Tribble almost 2 years ago

  • Status changed from New to Closed

Fixed in 8212

Also available in: Atom PDF