Project

General

Profile

Bug #4364

Assertion (type != ZIO_TYPE_WRITE || spa_writeable(spa)) triggered trying to import pool with cache vdevs in readonly mode

Added by Yuri Pankov over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
zfs - Zettabyte File System
Start date:
2013-11-27
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:

Description

Trying to import pool with cache vdevs in readonly mode triggers the following assertion:

type != ZIO_TYPE_WRITE || spa_writeable(spa)

http://article.gmane.org/gmane.os.illumos.zfs/2449/


Related issues

Is duplicate of illumos gate - Bug #4121: vdev_label_init should treat request as succeeded when pool is read onlyClosed2013-09-09

Actions

History

#1

Updated by Yuri Pankov over 5 years ago

  • Status changed from New to Rejected

Duplicates #4121 (sorry).

Also available in: Atom PDF