Project

General

Profile

Bug #4366

::walk zio and ::zio_state are broken

Added by Christopher Siden over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
mdb - modular debugger
Start date:
2013-11-29
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Analysis by Matt Ahrens:

"::walk zio" and "::zio_state" don't output anything, even though "::walk
zio_cache" shows that there are zio's on the system.

The problem is incorrect use of the walk_addr.

introduced by: bug 3468


Related issues

Related to illumos gate - Bug #3468: mdb enhancements for zfs developmentResolved2013-01-11

Actions

History

#1

Updated by Christopher Siden over 5 years ago

  • Status changed from In Progress to Closed
commit dee140df5444b21d7034d3c528e68f193f96244c
Author: Matthew Ahrens <mahrens@delphix.com>
Date:   Sat Nov 30 15:59:02 2013

    4366 ::walk zio and ::zio_state are broken
    Reviewed by: Christopher Siden <christopher.siden@delphix.com>
    Reviewed by: Adam Leventhal <ahl@delphix.com>
    Approved by: Gordon Ross <gwr@nexenta.com>

Also available in: Atom PDF