Project

General

Profile

Feature #4372

ZFS embedded-data block pointers ("zero block compression")

Added by Christopher Siden over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Category:
zfs - Zettabyte File System
Start date:
2013-12-01
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Originally filed by Matt Ahrens:

ZFS should allow highly-compressible blocks to have their compressed data
stored in the block pointer itself.  This provides a space savings and
performance improvement (not having to write/read these blocks).

The benefit should be seen when an application creates highly compressible blocks (e.g. some applications write block "headers" to every file system block, but leave the rest of the block untouched, if the header can be compressed to less than the size of a bp this feature can be used). It should also help compress some of ZFS's internal metadata.

History

#1

Updated by Matthew Ahrens about 5 years ago

  • Status changed from In Progress to Closed

duplicate of 4757 ZFS embedded-data block pointers ("zero block compression")

Also available in: Atom PDF