Project

General

Profile

Bug #4399

mpt_sas should not do tasw

Added by Zhiwen Zheng almost 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
driver - device drivers
Start date:
2013-12-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

/pci@0,0/pci8086,105@1,1/pci1000,3060@0 (mpt_sas0):
        Log info 0x31120303 received for target 16.
        scsi_status=0x0, ioc_status=0x804b, scsi_state=0xc
WARNING: /pci@0,0/pci8086,105@1,1/pci1000,3060@0 (mpt_sas0):
        mptsas_check_task_mgt: Task 0x3 failed. IOCStatus=0x4b IOCLogInfo=0x0 target=16

WARNING: /pci@0,0/pci8086,105@1,1/pci1000,3060@0 (mpt_sas0):
        mptsas_ioc_task_management failed try to reset ioc to recovery!

panic[cpu0]/thread=ffffff0011bb4c40: 
assertion failed: tq != curthread->t_taskq, file: ../../common/os/taskq.c, line: 1325

ffffff0011bb4820 genunix:process_type+17b920 ()
ffffff0011bb4860 genunix:taskq_wait+108 ()
ffffff0011bb4880 genunix:ddi_taskq_wait+11 ()
ffffff0011bb48e0 mpt_sas:mptsas_flush_hba+214 ()
ffffff0011bb4920 mpt_sas:mptsas_restart_ioc+89 ()
ffffff0011bb49d0 mpt_sas:mptsas_ioc_task_management+2c6 ()
ffffff0011bb4a30 mpt_sas:mptsas_do_scsi_reset+b0 ()
ffffff0011bb4af0 mpt_sas:mptsas_handle_topo_change+541 ()
ffffff0011bb4b60 mpt_sas:mptsas_handle_dr+12c ()
ffffff0011bb4c20 genunix:taskq_thread+318 ()
ffffff0011bb4c30 unix:thread_start+8 ()

syncing file systems...
 done
dumping to /dev/zvol/dsk/rpool/dump, offset 65536, content: kernel
NOTICE: ahci0: ahci_tran_reset_dport port 2 reset port


Related issues

Related to illumos gate - Bug #3195: mpt_sas IOC reset races can cause panicsResolved2012-09-14

Actions
Is duplicate of illumos gate - Bug #4310: Another mpt_sas panicClosed2013-11-10

Actions

History

#1

Updated by Zhiwen Zheng almost 6 years ago

sorry for not complete the subject.

mpt_sas should not wait on mpt->m_dr_taskq in mptsas_flush_hba, as mpt_sas_flush_hba may be called by the dr_taskq thread

#2

Updated by Zhiwen Zheng almost 6 years ago

this is duplicate of 4310

#3

Updated by Zhiwen Zheng almost 6 years ago

Is it safe to not wait on m_dr_taskq in mptsas_flush_hba ?

#4

Updated by Marcel Telka over 2 years ago

  • Status changed from New to Closed
#5

Updated by Marcel Telka over 2 years ago

  • Category set to driver - device drivers
#6

Updated by Marcel Telka over 2 years ago

  • Related to Bug #3195: mpt_sas IOC reset races can cause panics added

Also available in: Atom PDF