Project

General

Profile

Bug #44

horizontal scrolling bar occurs

Added by Rafael Gieschke over 10 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Low
Target version:
-
Start date:
2010-08-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

At least in Webkit an Gecko an horizontal scrolling bar is forced by this line in http://www.illumos.org/themes/nexentastor/stylesheets/application.css?1280401680 :

#footer {background-color:#EEEEEE;border:0 none;color:#666666;font-size:9px;padding-bottom:15px;text-align:left;margin-top:20px; width:100%;bottom:0};

either width: 100% has to go away or the following definitions have to be added:

box-sizing: border-box;
-moz-box-sizing: border-box;
-webkit-box-sizing: border-box;

The horizontal scrolling bar gives the website a very unprofessional look.


Files

#1

Updated by Andre van Eyssen over 10 years ago

  • Status changed from New to In Progress
  • Assignee set to Andre van Eyssen
  • Priority changed from Normal to Low

I've had a look and updated the stylesheet to implement your "box-sizing" requests. However, I'm not quite sure what the problem is - a horizontal scrollbar is only visible when the window is resized too small to fit all the elements in there. I don't see any difference in browser behaviour before/after the modification

I'm not a web guy; can you explain a little more and/or send me a screenshot to clarify please?

#2

Updated by Rafael Gieschke about 10 years ago

Sorry for the late reply.

The problem is that paddings are normally not included in the width. So if you specify a width of 100 % + a padding of an additional 5px, the total size of the footer box will be 100%+5px, as you can seen in the attached screenshot.

Internet Explorer in older versions didn't adhere to this specification of the "box model" but instead would include the padding in the width and thus make the footer box only 100% wide. For compatibility, Internet Explorer still uses the false "box model", in some circumstances. You can read about this in more detail in Wikipedia: http://en.wikipedia.org/wiki/Internet_Explorer_box_model_bug .

#3

Updated by Bryan Horstmann-Allen almost 2 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF