Project

General

Profile

Actions

Bug #4429

closed

hipster: after last recompilation Apache PHP 5.4 32-bit module crashes on startup

Added by Alexander Pyhalov over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
High
Category:
OI-Userland
Target version:
-
Start date:
2013-12-24
Due date:
2014-01-24
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

After last update something is wrong with 32-bit php module. It crashes on startup.
I suppose _FILE_OFFSET_BITS issue in php or one of the required libraries .

Stack trace:

#0 0xfcb9cb15 in zend_hash_internal_pointer_reset_ex () from /usr/apache2/2.2/libexec/mod_php54.so
#1 0xfcc92c9d in apply_config () from /usr/apache2/2.2/libexec/mod_php54.so
#2 0xfcc921ad in php_handler () from /usr/apache2/2.2/libexec/mod_php54.so
#3 0x080898e1 in ap_invoke_handler ()
#4 0x08099058 in ap_process_request ()
#5 0x08095a98 in ap_process_http_connection ()
#6 0x080916a5 in ap_process_connection ()
#7 0x0809fe43 in child_main ()
#8 0x080a0aa2 in ap_mpm_run ()
#9 0x080ac032 in main ()

Actions #1

Updated by Alexander Pyhalov over 7 years ago

It's definitely not a _FILE_OFFSET_BITS issue in php. It is set correctly.

Actions #2

Updated by Alexander Pyhalov over 7 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

It seems the issue was caused by bdb update (not sure, but at least apr and apache data types were incompatible). After recompilation of apr, apr-util, php and apache modules issue has gone.

Actions #3

Updated by Ken Mays over 7 years ago

  • Due date set to 2014-01-24
  • Category set to 10
  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF