Project

General

Profile

Actions

Bug #445

closed

pkg fix reports errors in SUNWcs after reboot

Added by Jon Tibble about 13 years ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
2010-12-05
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:

Description

After reboot pkg fix will report errors in SUNWcs that it will let you fix...

jt@oidev0:~$ pfexec pkg fix SUNWcs
Verifying: pkg://openindiana.org/SUNWcs ERROR
file: var/spool/cron/crontabs/root
Group: 'root (0)' should be 'sys (3)'
hardlink: etc/rc2.d/S82mkdtab
Missing: regular file does not exist
Created ZFS snapshot: 2010-12-06-01:29:16
Repairing: pkg://openindiana.org/SUNWcs

DOWNLOAD PKGS FILES XFER (MB)
Completed 1/1 22/22 0.0/0.0

PHASE ACTIONS
Update Phase 23/23

PHASE ITEMS
Package State Update Phase 1/1
Package Cache Update Phase 1/1
Image State Update Phase 2/2
jt@oidev0:~$ pfexec pkg fix SUNWcs
jt@oidev0:~$

but then you get exactly the same after the next reboot.


Related issues

Related to illumos gate - Bug #2187: EOF mkdtab infrastructureResolvedMilan Jurik2012-02-26

Actions
Actions #1

Updated by Julian Wiesener over 12 years ago

  • Assignee set to Julian Wiesener
  • Difficulty set to Medium
  • Tags set to needs-triage

pkg fix is dangerous here, what it will do is very unpleasant

it will replace your root crontab by a default crontab (all your cronjobs are gone), since some smf start methots edit the root crontab, it will occour over and over, pkg fix is just the wrong idear here.

S82mkdtab will remove it self on start, thus it can't impossibel be ever persitently fixed.

it will btw. "fix" much more...
/etc/hosts will be empty after "fix"
/etc/nsswitch.conf will be defaulted (no more ldap if you had it)
/root/.bashrc will be defaulted
/etc/logadm.conf will be defaulted (no more logrotation for apache and friends)

so i assume, that is no bug. If you really think we should make every package "fixable" we would need to modify pkg that fix doesn't fix configuration files, but how should we fix config-files then? rm && pkg fix?)

Actions #2

Updated by Julian Wiesener over 12 years ago

  • Assignee changed from Julian Wiesener to OI illumos

the files content will not change, however someone will need to fix it in illumos (modify the scripts that change the file permissions) or just remove some bits like S82mkdtab. I'm not sure that crintab and root bashrc is listed as configfile in ips already. There might also be non-illumos sources, however we will need to care separately

Actions #3

Updated by Milan Jurik about 12 years ago

mkdtab has to be replaced with SMF service and not done as it is now.

Actions #4

Updated by Milan Jurik over 10 years ago

  • Tags deleted (needs-triage)

"#2187 EOF mkdtab infrastructure" fixed part of this.

Actions #5

Updated by Marcel Telka about 2 months ago

  • Related to Bug #2187: EOF mkdtab infrastructure added
Actions #6

Updated by Marcel Telka about 1 month ago

  • Status changed from New to Closed

I'm unable to reproduce this issue. pkg verify SUNWcs shows no issues and pkg fix -nv SUNWcs shows bunch of files with editable file has been changed note only. That's expected and pkg fix won't try to fix that.

Actions

Also available in: Atom PDF