Project

General

Profile

Actions

Bug #4452

closed

Firefox 17 package incomplete on /hipster

Added by Predrag Zečević over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2014-01-10
Due date:
2014-01-12
% Done:

100%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
firefox

Description

Hi,

http://wiki.openindiana.org/oi/oi_hipster states:
"2014-01-08 Firefox is updated to 17.0.6 ESR,..."

But packages contains wrong elements:

$ pkg contents web/browser/firefox | grep path
path=usr/lib/firefox/extensions/langpack-es-CL@firefox.mozilla.org.xpi
usr/include/firefox/nsIDOMSVGMpathElement.h
usr/share/idl/firefox/nsIDOMSVGMpathElement.idl

So, 1st entry installs into /:
find /path\\=usr/
/path=usr/
/path=usr/lib
/path=usr/lib/firefox
/path=usr/lib/firefox/extensions
/path=usr/lib/firefox/extensions/langpack-es-CL@firefox.mozilla.org.xpi

Version of /hipster:
$ uname -rosv
SunOS 5.11 illumos-ee169c7 Solaris

Regards.

Actions #1

Updated by Predrag Zečević over 7 years ago

...and can we get (at least) version 24-esr instead?

Actions #2

Updated by Alexander Pyhalov over 7 years ago

Sorry, fixed in https://github.com/OpenIndiana/oi-userland/commit/2d7a5681247e4a6826df24dc7e46c709e4bca70c.
As for 24-esr, I'm not sure about "instead" - there are issues with some extensions (at least I couldn't make Adbobe plugin work with it). Also, as they deprecated libxpcom, some JDS stuff is very unhappy about it.

Actions #3

Updated by Ken Mays over 7 years ago

  • Due date set to 2014-01-12
  • Category changed from OpenIndiana Misc to 10
  • Status changed from New to Closed
  • Assignee set to OI Userland
  • % Done changed from 0 to 100
  • Estimated time set to 1.00 h
  • Tags changed from needs-triage to firefox

Fixed in ,5.11-0.151.1.8.1:20140110T130904Z.

Actions

Also available in: Atom PDF