Project

General

Profile

Actions

Bug #4482

closed

mutt segfault at imap_fetch_message+0x6af()

Added by Marcel Telka over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
OI-Userland
Target version:
-
Start date:
2014-01-15
Due date:
2014-01-31
% Done:

0%

Estimated time:
1.00 h
Difficulty:
Medium
Tags:
mutt

Description

> ::status
debugging core file of mutt (32-bit) from telcontar
file: /usr/bin/mutt
initial argv: mutt -F .muttrc-telka.sk
threading model: native threads
status: process terminated by SIGSEGV (Segmentation Fault), addr=4
> ::stack
imap_fetch_message+0x6af(8253a88, 8293890, 0, fefd282e, fefa0034, 8044ac4)
mx_open_message+0x9b(8293890, 0, 6, 7, 70616d69, 73)
mutt_prepare_template+0x585(0, 8293890, 826c578, 826c748, 0, 8044dc0)
mutt_get_postponed+0x8c(8382018, 826c578, 80467d0, 8044ea0, ff, 8044e30)
ci_send_message+0x2198(10, 826c578, 0, 8382018, 0, 0)
mutt_index_menu+0x2d4e(80472d0, 0, 0, 811a7ca, fefc35f5, fec80578)
main+0xf8f(3, 8047a20, 8047a30, 8066c02, 8113480, 0)
_start+0x83(3, 8047b34, 8047b39, 8047b3c, 0, 8047b4d)
>

This is with hipster from 2013-12-27 (Mutt 1.5.22).


Related issues

Related to OpenIndiana Distribution - Bug #4231: mutt segfault at index_color+0x80()ClosedKen Mays2013-10-182013-12-04

Actions
Related to OpenIndiana Distribution - Feature #4232: Update mutt to 1.5.22ResolvedMarcel Telka2013-10-18

Actions
Actions #1

Updated by Alexander Pyhalov over 7 years ago

Is it reproducible or one-time issue?

Actions #2

Updated by Marcel Telka over 7 years ago

No. It just happened. I used mutt as I use it everyday. Nothing special, and it suddenly segfaulted (I think during fetching a postponed message).

Actions #3

Updated by Ken Mays over 7 years ago

  • Due date set to 2014-01-31
  • Status changed from New to In Progress
  • Estimated time set to 1.00 h
  • Tags changed from needs-triage to mutt

Missing some patches from Oracle upstream?

Actions #4

Updated by Marcel Telka over 7 years ago

We intentionally removed all three patches during the upgrade of mutt to 1.5.22 because all those patches were upstreamed (hint: look at changes in PATCHES.patch during the uprev). Oracle is still at 1.5.21.

https://github.com/OpenIndiana/oi-userland/commit/cd1804985b6eed1303990deddeec05c787ae4b2a

Actions #5

Updated by Ken Mays almost 7 years ago

  • Status changed from In Progress to Closed
  • Assignee changed from Marcel Telka to Ken Mays

I'm taking over this ticket (pushing to mutt 1.5.23). One main thing if you'd like to reopen this ticket: consult the mutt developers and have them repeat or confirm they can reproduce the bug themselves in Mutt 1.5.23 (what I'm committing in oi-userland. This bug was open for six months and NO patches or mutt-developer confirmation other than ((possibly) fixed) exists in their current bug reports). Also, you should provide a test procedure on how to reproduce the bug to oi-userland so it can be worked on or retested. Without those critical pieces of data, we can only do so much...

Actions #6

Updated by Marcel Telka over 6 years ago

The segfault happened again today. With mutt 1.5.23 (recent OI Hipster).

Actions

Also available in: Atom PDF