Project

General

Profile

Bug #458

'beadm mount' needs improvements

Added by Jeppe Toustrup over 8 years ago. Updated over 8 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
cmd - userland programs
Start date:
2010-12-07
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:

Description

When trying to mount a BE, you currently have to specify a path to an empty directory which does not end with a tailing slash, otherwise beadm will spit out the following error:

# beadm mount be_name /mnt/
Unable to mount be_name.
Mount failed.

Where as running the command with '/mnt' as the last parameter works just fine.

I suggest that a simple stripping of the tailing slash (if included) is put into the code, since the current behavior is non-obvious and apparently not documented anywhere.

History

#1

Updated by Garrett D'Amore over 8 years ago

  • Status changed from New to Rejected

Not reproducible. There is something else wrong. This works fine for me on illumos:

% pfexec beadm mount b134 /mnt/

Closing this one as rejected.

Also available in: Atom PDF