Project

General

Profile

Actions

Bug #4582

closed

hipster: apache2 component publish dependencies are wrong

Added by Alexander Pyhalov over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
2014-02-06
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Apache 2 component in oi-userland is not automatically published after Makefile change.
It seems that it is caused by non-standard directories used for building apache2:
build/prefork/{i86,amd64} and build/worker/{i86,amd64} and not build/{i86,amd64}.
So perhaps build/.published target has wrong dependencies.

Actions #1

Updated by Alexander Pyhalov over 8 years ago

How to repeat:

cd oi-userland/components/apache2
gmake publish
touch Makefile
gmake publish

The second publish doesn't actually publish packages.

Actions #2

Updated by Alexander Pyhalov over 8 years ago

  • Assignee set to Alexander Pyhalov
  • % Done changed from 0 to 100

The reason is that ips.mk targets depend on $(BUILD_DIR). Second install will not modify $(BUILD_DIR), and so ips.mk target will not be considered old. Should be fixed in https://github.com/OpenIndiana/oi-userland/commit/639c689725f4048ff1e2dbfe681afc4d695273c6

Actions #3

Updated by Ken Mays almost 8 years ago

  • Status changed from New to Closed
Actions

Also available in: Atom PDF