Project

General

Profile

Actions

Bug #4643

closed

nss_dns fails to obtain dns ttls

Added by Robert Mustacchi over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Category:
lib - userland libraries
Start date:
2014-02-27
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

nscd can end up not honoring dns ttls that are. This happens because of nss_dns. Specifically the nss_dns interface to retrieve the dns information and ttls explicitly bails whenever it encounters any flags defined in netdb.h are set. These include the standard AI_V4MAPPED, AI_ALL, and AI_ADDRCONFIG. Because this is the case we fall back to a local resolver which doesn't give us any kind of ttl information at all. This means that applications may end up with the default ttl which leads to rather strange and unexpected behavior. The fix for this is to implement this logic.

Actions #1

Updated by Electric Monk over 6 years ago

  • Status changed from New to Closed
  • % Done changed from 80 to 100

git commit e48cae6f8c603e9a18cdb49fdf939cd4e1753e62

commit  e48cae6f8c603e9a18cdb49fdf939cd4e1753e62
Author: Robert Mustacchi <rm@joyent.com>
Date:   2014-12-10T23:24:01.000Z

    4643 nss_dns fails to obtain dns ttls
    Reviewed by: Joshua M. Clulow <jmc@joyent.com>
    Reviewed by: Dan McDonald <danmcd@omniti.com>
    Reviewed by: Richard Lowe <richlowe@richlowe.net>
    Approved by: Gordon Ross <gwr@nexenta.com>

Actions

Also available in: Atom PDF