Project

General

Profile

Bug #4669

cpqary3 driver does not see drives on P400 Smart-Array

Added by Josef Sipek about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
driver - device drivers
Start date:
2014-03-05
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

The open-source cpqary3 driver fails to probe drives.

The issue is actually in the package manifest. It classifies the driver as 'scsi-self-identifying' instead of just 'scsi'. (The closed source driver uses the 'scsi' class, and the open-source driver is obviously based on the same codebase.) This makes devcfg expect that the HBA driver sets certain properties. Their absence terminates the bus probe preventing devices from showing up.

Anyone shipping IPS packages or creating packages based on the IPS manifests in the gate will run into this issue. Joyent hasn't seen this issue since their /etc/driver_clasess ships with 'scsi' for cpqary3.

History

#1

Updated by Robert Mustacchi about 5 years ago

  • Status changed from New to Resolved
  • % Done changed from 80 to 100
  • Tags deleted (needs-triage)
#2

Updated by Electric Monk about 5 years ago

git commit cb4d2fc89a3412669ae5ad0126ddbf6501c7ce39

Author: Josef 'Jeff' Sipek <josef.sipek@nexenta.com>

4669 cpqary3 driver does not see drives on P400 Smart-Array
Reviewed by: Richard Lowe <richlowe@richlowe.net>
Reviewed by: Dan McDonald <danmcd@omniti.com>
Reviewed by: Keith Wesolowski <keith.wesolowski@joyent.com>
Reviewed by: Albert Lee <trisk@nexenta.com>
Reviewed by: Hans Rosenfeld <hans.rosenfeld@nexenta.com>
Approved by: Robert Mustacchi <rm@joyent.com>

Also available in: Atom PDF