Project

General

Profile

Actions

Bug #4685

closed

jokosher dumps core when new audio file is added to the project (hipster)

Added by Alexander Pyhalov over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
-
Start date:
2014-03-13
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

While rebuilding jokosher I've found out that both current and new version dumps core while I try to add new audio file to the project.

$ mdb /usr/bin/python2.6 core
Loading modules: [ libc.so.1 libpython2.6.so.1.0 libuutil.so.1 libnvpair.so.1 ld.so.1 ]
> $C
f42de7d4 libvorbis.so.0.4.6`_book_unquantize+0x34(9055850, 51, f42de7f0, 3, 3, 0)
f42deaf4 libvorbis.so.0.4.6`vorbis_book_init_decode+0x1d5(9068400, 9055850, f42f0f8c, f4353cb1, f4380118, fefa0518)
f42deb54 libvorbis.so.0.4.6`_vds_shared_init+0x4fc(0, 904b048, 0, 904b1a4, f4376770, 0)
f42deb74 libvorbis.so.0.4.6`vorbis_synthesis_init+0x2b(904b1a4, 904b20c)
f42debb4 libgstvorbis.so`vorbis_handle_type_packet+0x3f(904b048, 0)
f42debfc libgstvorbis.so`vorbis_handle_header_packet+0x103(904b048, f42dec34)
f42dec6c libgstvorbis.so`vorbis_dec_handle_frame+0x189(904b048, 9037660) 
f42decb8 libgstaudio-0.10.so.0.25.0`gst_audio_decoder_handle_frame+0x29f(904b048, 8f0c300, 9037660)
f42ded20 libgstaudio-0.10.so.0.25.0`gst_audio_decoder_push_buffers+0x428(904b048, 0) 
f42ded54 libgstaudio-0.10.so.0.25.0`gst_audio_decoder_chain_forward+0xc3(904b048, 0) 
f42dedb8 libgstaudio-0.10.so.0.25.0`gst_audio_decoder_chain+0x4df(9018b30, 9037660, 0, fc9c1f99) 
f42dee08 libgstreamer-0.10.so.0.30.0`gst_pad_push+0x167(9018a68, 9037660, 0, f49c42be)
f42dee78 libgstcoreelements.so`gst_queue_push_one+0x157(8f067e8, 0, 0, f49c470a)
f42deed8 libgstcoreelements.so`gst_queue_loop+0x44b(9018a68)
f42def28 libgstreamer-0.10.so.0.30.0`gst_task_func+0x227(8413ea8, 8412140, f42def58, fc9f62da)
f42def58 libgstreamer-0.10.so.0.30.0`default_func+0x2e(8412140)
f42def88 libglib-2.0.so.0.2800.6`g_thread_pool_thread_proxy+0x58(84b3dc0, 8f03998, 0, fe9dbf5a)
f42defc8 libglib-2.0.so.0.2800.6`g_thread_create_proxy+0x12e(8f03998, 0, 0, 0)
f42defe8 libc.so.1`_thrp_setup+0x88(fd1d1240)  
f42deff8 libc.so.1`_lwp_start(fd1d1240, 0, 0, 0, 0, 0)                 

Actions #1

Updated by Alexander Pyhalov over 8 years ago

If I add ogg file, core dump is immediate, if I add wav file, core is dumped with a bit different stack trace when I'm trying to play it. Perhaps, it's worth rebuilding gstreamer and gstreamer plugins.

Actions #2

Updated by Alexander Pyhalov over 8 years ago

  • Status changed from New to In Progress
  • Assignee set to Alexander Pyhalov
  • % Done changed from 0 to 100

The issue is resolved after rebuilding gstreamer, python gstreamer library and jokosher.

Actions #3

Updated by Ken Mays almost 8 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF