Project

General

Profile

Bug #4731

Remove NIS+ from man pages

Added by Marcel Telka almost 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
manpage - manual pages
Start date:
2014-04-07
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

There are several places in the getpublickey(3nsl) man page where NIS+ left. NIS+ should be removed from the man page.

         o    NIS map  ``publickey.byname''  or  the  NIS+  table
              ``cred.org_dir''.   The  sources  and  their lookup
              order are specified in the /etc/nsswitch.conf file.
              See nsswitch.conf(4).
WARNINGS
     If getpublickey() gets the public key from any source  other
     than  NIS+,  all  authenticated NIS+ operations may fail. To
     ensure that this does not happen, edit the  nsswitch.conf(4)
     file to make sure that the public key is obtained from NIS+.

  NOTES
     NIS+ might not  be  supported  in  future  releases  of  the
     Solaris  operating  system.  Tools to aid the migration from
     NIS+ to LDAP are available in the current  Solaris  release.
     For            more            information,            visit
     http://www.sun.com/directory/nisplus/transition.html.

In addition, the following man pages contains word "nisplus": newkey(1m), lpset(1m), keyserv(1m), dhcpconfig(1m), nsswitch.conf(4), bootparams(4), dhcpsvc.conf(4), group(4), prof_attr(4), auth_attr(4), passwd(1), chkey(1), keylogout(1), keylogin(1), login(1), getpublickey(3nsl), getgrnam(3c), getpwnam(3c), and sharemgr(1m). There is also bunch of man pages containing "NIS+". We should review all of such man pages and remove "nisplus" and "NIS+" from them eventually.


Related issues

Related to illumos gate - Bug #4812: libnsl: Some nisplus leftoversClosed2014-04-26

Actions
Is duplicate of illumos gate - Bug #4339: NIS+ should be removed from man pages tooClosed2013-11-19

Actions

History

#1

Updated by Marcel Telka almost 6 years ago

  • Subject changed from getpublickey(3nsl): Remove NIS+ from the man page to Remove NIS+ from man pages
#2

Updated by Bart Coddens almost 6 years ago

  • Status changed from New to In Progress

I'm working on it

#3

Updated by Marcel Telka almost 6 years ago

  • Assignee set to Bart Coddens
#4

Updated by Marcel Telka about 3 years ago

  • Status changed from In Progress to Feedback
#5

Updated by Marcel Telka about 3 years ago

  • Status changed from Feedback to Closed
#6

Updated by Marcel Telka about 3 years ago

  • Related to deleted (Bug #4339: NIS+ should be removed from man pages too)
#7

Updated by Marcel Telka about 3 years ago

  • Is duplicate of Bug #4339: NIS+ should be removed from man pages too added

Also available in: Atom PDF