Project

General

Profile

Actions

Bug #4739

closed

stellarium not running

Added by r a about 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-04-09
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi,

After upgrading to /Hipster illumos-7a3fc0c I re-installed in Stellarium and when it is run the following output is produced.

#more log.txt
2014-04-09T22:26:44
Unknown operating system
Non-GCC compiler
Qt runtime version: 4.7.4
Qt compilation version: 4.7.4
Addressing mode: 32-bit
stellarium
-------------------------------------------------------
[ This is Stellarium 0.11.3 - http://www.stellarium.org ]
[ Copyright (C) 2000-2012 Fabien Chereau et al ]
-------------------------------------------------------
Writing log file to: "/home/russell/.stellarium/log.txt"
File search paths:
0 . "/home/russell/.stellarium"
1 . "/usr/share/stellarium"
Attempting to use an existing older config file.
Config file is: "/home/russell/.stellarium/config.ini"
QPixmap::handle(): Pixmap is not an X11 class pixmap
OpenGL supported version: "4.4.0 NVIDIA 334.16"
Qt GL paint engine is: "OpenGL2"
Vertex shader for simpleShaderProg (MainVertexShader & PositionOnlyVertexShader)
failed to compile
Fragment shader for simpleShaderProg (MainFragmentShader & ShockingPinkSrcFragme
ntShader) failed to compile
QGLShaderProgram: shader programs are not supported

I am currently using Nvidia Driver NVIDIA-Solaris-x86-334.16.

Actions #1

Updated by Ken Mays almost 8 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Rebuild your Qt for OpenGL support. Qt works as provided by SFE project.

Actions

Also available in: Atom PDF