Project

General

Profile

Actions

Bug #4885

closed

EOF scsi_hba_attach

Added by Garrett D'Amore about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2014-05-24
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

The legacy SCSI routine scsi_hba_attach() was deprecated back in Solaris 8 time frame; nobody uses it anymore. (I've checked all the HBA drivers I could lay hands on.)

Its time to remove it -- it is one of the last documented consumers of ddi_dma_lim_t.


Related issues

Is duplicate of illumos gate - Bug #4884: EOF scsi_hba_attachClosedGarrett D'Amore2014-05-24

Actions
Actions #1

Updated by Garrett D'Amore about 8 years ago

  • Status changed from New to Closed

This was accidentally resubmitted. Its a dup of 4884.

Actions

Also available in: Atom PDF