Project

General

Profile

Bug #4926

sem_timedwait(3c) man page missing EAGAIN description

Added by Jason King over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
manpage - manual pages
Start date:
2014-06-16
Due date:
% Done:

0%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

The current sem_timedwait(3c) manpage does not list EAGAIN as a possible error value. However, sem_wait(3c) does. Testing does show that sem_timedwait(3c) can return EAGAIN.

As the error for sem_wait(3c) means 'already locked', the distinction between bounded and unbounded wait time here is irrelevant and EAGAIN should be documented in the sem_timedwait manpage.

History

#1

Updated by Jason King over 5 years ago

Gah it's late -- this should be sem*a*_timedwait. However as the Posix versions are nothing but thin wrappers to the Solaris sema_ versions, this is also true for their man page as well.

#2

Updated by Jason King over 5 years ago

  • Status changed from New to Rejected

There was a subtle bug in the test that took me an embarrassingly long amount of time to spot. With that fixed (and with closer inspection of the source), this is not a bug.

Also available in: Atom PDF