Project

General

Profile

Actions

Bug #4941

closed

CPU Performance Counters support for Xeon E55xx, E56xx, E5 and E5v2

Added by Josef Sipek about 7 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Category:
kernel
Start date:
2014-06-27
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

We lack support for CPU performance counters for the last few generations of Intel Xeons. This is making performance issues harder to troubleshoot, and limits our ability to do in-depth instruction-level or memory/cache statistics tracing for code optimization. (cpustat, cputrack and DTrace CPC provider are not functional on all recent Intel systems)


Related issues

Related to illumos gate - Bug #2769: performance counter support for AMD CPU families > 0x11NewHans Rosenfeld2012-05-23

Actions
Related to illumos gate - Bug #5800: want newer Intel processor branch trace supportNew2015-04-08

Actions
Is duplicate of illumos gate - Feature #10212: Autogenerate Intel pcbe values from perfmon dataClosedRobert Mustacchi2019-01-11

Actions
Actions #1

Updated by Robert Mustacchi almost 2 years ago

  • Status changed from New to Closed
  • Assignee set to Robert Mustacchi
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

This was taken care of with 10212.

Actions #2

Updated by Robert Mustacchi almost 2 years ago

  • Is duplicate of Feature #10212: Autogenerate Intel pcbe values from perfmon data added
Actions

Also available in: Atom PDF