Project

General

Profile

Bug #496

heraia's interface is partially localized correctly

Added by Olivier DELHOMME almost 9 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
Internationalisation
Target version:
-
Start date:
2010-12-10
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Heraia uses a gtkbuilder interface. Part of it is from gtk's defaults (New, open, ...). The rest of the interface is localized via heraia.mo file (found in locale subdirectories). The problem is that the gtk default part appears correctly localized whereas the rest of the interface is in default language (ie not localized). I enclose an image as it worth a thousand words

The problem appears only under openindiana (tested under fedora, opensuse, ubuntu, debian and windows XP).


Files

half_localized.png (195 KB) half_localized.png heraia's interface partly localized Olivier DELHOMME, 2010-12-10 11:32 AM

History

#1

Updated by Albert Lee almost 9 years ago

  • Category set to Internationalisation
  • Target version deleted (oi_147)

This is probably an issue with how your application was built. *.mo is a binary msgfmt catalog, did you use the correct msgfmt to compile it? The formats are implementation specific and differ between the system msgfmt and GNU msgfmt; due to the presence of /usr/gnu/bin in the default PATH, the latter may be picked up by accident.

You should probably create a spec file using the Desktop CBE to build your application, see examples in SFE which use export MSGFMT="/usr/bin/msgfmt".

#2

Updated by Olivier DELHOMME almost 9 years ago

Good catch. /usr/gnu/bin/msgfmt is used. However when /usr/bin/msgfmt (by exporting MSGFMT environment variable) the configure script complains because /usr/bin/gmsgfmt does not have --version option and the program cannot be compiled.

Please let me know what is SFE and where can I found the examples you are talking about ?

#3

Updated by Chris Jordan about 8 years ago

  • Status changed from New to Feedback
  • Difficulty set to Medium
  • Tags set to needs-triage

Olivier Delhomme, I see this issue has not been updated for 7 months. Is the issue you reported still a problem? To answer your question, "SFE" is "Spec-Files-Extra". It is "is a repository of RPM-like spec files for building Solaris SVr4 packages from various Open Source modules". For more information see: http://pkgbuild.sourceforge.net/spec-files-extra/

#4

Updated by Chris Jordan about 8 years ago

  • Status changed from Feedback to Closed

Closing since there was no response to feedback. Please open a new bug if you are still having issues.

Also available in: Atom PDF