Feature #4960

import latest LSI MPI header files from FreeBSD driver

Added by Hans Rosenfeld about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:2014-07-03
Priority:NormalDue date:
Assignee:Hans Rosenfeld% Done:

100%

Category:driver - device drivers
Target version:-
Difficulty:Bite-size Tags:needs-triage

Description

In preparation for the 12G mpt_sas support (issue 4546), we need the newest MPI headers that support MPI 2.5.

The new headers work very well with the existing mpt_sas driver. The binary changes in two locations only, caused by the increased size of struct MPI2_SCSI_TASK_MANAGE_REPLY and the new version numbers. There are no functional changes.

History

#1 Updated by Electric Monk about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 11cb6ef00e4913c161e88403c11c037fb2afab44

commit  11cb6ef00e4913c161e88403c11c037fb2afab44
Author: Andy Giles <illumos@ang.homedns.org>
Date:   2014-07-21T20:03:18.000Z

    4960 import latest LSI MPI header files from FreeBSD driver
    Reviewed by: Hans Rosenfeld <hans.rosenfeld@nexenta.com>
    Reviewed by: Albert Lee <trisk@nexenta.com>
    Reviewed by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
    Reviewed by: Dan McDonald <danmcd@omniti.com>
    Approved by: Gordon Ross <gwr@nexenta.com>

Also available in: Atom