Project

General

Profile

Bug #5014

etherstubs confuse min mtu with min sdu

Added by Robert Mustacchi over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Category:
networking
Start date:
2014-07-17
Due date:
% Done:

100%

Estimated time:
Difficulty:
Bite-size
Tags:

Description

6824511 check the MTU value that can be set on an etherstub, introduced changes to the vnic driver to set the range for the MTU of an etherstub. While it established a lower bound for the MTU, the code also set that as the minimum size SDU. This is used by dlpi in the DL_INFO_ACK with the member dl_max_sdu and dl_min_sdu. These are meant to describe the minimum sized frame that can be transmitted on these devices which is honored by vnd. The problem is that the dl_min_sdu was set to the minimum size MTU. The minimum size MTU is definitely not the value of the minimum size frame that can be set.

History

#1

Updated by Electric Monk over 5 years ago

  • Status changed from New to Closed

git commit dcb12fb726d8dd4ff80ea255dc3f53b5692c75e5

commit  dcb12fb726d8dd4ff80ea255dc3f53b5692c75e5
Author: Robert Mustacchi <rm@joyent.com>
Date:   2014-07-18T22:03:07.000Z

    5014 etherstubs confuse min mtu with min sdu
    Reviewed by: Dan McDonald <danmcd@omniti.com>
    Reviewed by: Garrett D'Amore <garrett@damore.org>
    Approved by: Garrett D'Amore <garrett@damore.org>

Also available in: Atom PDF