Bug #506

suspend/resume issue on b147 (6986810)

Added by Piotr Jasiukajtis over 3 years ago. Updated almost 3 years ago.

Status:Resolved Start date:2010-12-12
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:kernel Spent time: -
Target version:-
Difficulty:Medium Tags:

Description

Description: suspend/resume (actually suspend) does not work on build 147

This is a duplicate of:
http://bugs.opensolaris.org/view_bug.do?bug_id=6986810
https://defect.opensolaris.org/bz/show_bug.cgi?id=17093

Suggested fix:
two fix (6958308, 6970888) were done in backout.

Suggested workaround:

set pci_enable_wakeup = 0
to /etc/system

Tested on Lenovo T61 and OpenIndiana 147 and 148 builds.


Related issues

related to illumos gate - Bug #1817: USB ports dead after resume New 2011-11-25

History

Updated by Hans Rosenfeld about 3 years ago

This is not a duplicate of https://defect.opensolaris.org/bz/show_bug.cgi?id=17093.
The workaround is correct, but it won't help for 17093.

I observed this problem on my T61p. Using the workaround, my system is able to suspend and resume, but the USB ports are dead after resume.

Looking at the code for "6867140 ultra 27 does not resume from either mouse or keyboard event" which introduced this bug, I found that it enabled all PCI devices for wakeup, even those that don't support power management. Although I haven't worked with power management stuff before, I think this is wrong. Changing this fixes the resume problem on my T61p, but I don't have an ultra 27 to test it there.

I have been running oi_148 with using the attached diff for about a month now, without any resume or USB problems.

I also uploaded a webrev to http://cr.illumos.org/view/5ihk5w10/illumos-506-webrev/.

Updated by Garrett D'Amore almost 3 years ago

  • Subject changed from suspend/resume issue on b147 (6986810) to suspend/resume issue on b147 (6986810)
  • Difficulty set to Medium
  • Tags set to needs-triage

Updated by Garrett D'Amore almost 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
  • Tags deleted (needs-triage)

Resolved in:

changeset: 13363:ef9e6008c21c
tag: tip
user: Hans Rosenfeld <>
date: Fri May 06 10:04:21 2011 -0700
description:
506 suspend/resume issue on b147 (6986810)
Reviewed by: Richard Lowe <>
Reviewed by: Garrett D'Amore <>
Reviewed by: Albert Lee <>
Approved by: Garrett D'Amore <>

Also available in: Atom PDF