Project

General

Profile

Bug #5067

rpcgen should build ANSI compliant code only

Added by Garrett D'Amore about 6 years ago.

Status:
In Progress
Priority:
Normal
Category:
cmd - userland programs
Start date:
2014-08-05
Due date:
% Done:

90%

Estimated time:
Difficulty:
Medium
Tags:
Gerrit CR:

Description

There is no need for rpcgen to support generation of legacy K&R C code. Such code will not be compilable on illumos soon (see bug 5066), and all supported compilers support ANSI and define STDC. (The ANSI standard is 25 years old.)


Related issues

Related to illumos gate - Bug #5066: remove support for non-ANSI compilationClosed2014-08-05

Actions

Also available in: Atom PDF