Project

General

Profile

Bug #5109

Variable uninitialized in rpcbind.c

Added by Gary Mills about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2014-08-20
Due date:
% Done:

70%

Estimated time:
Difficulty:
Bite-size
Tags:
needs-triage

Description

A build of illumos on the SPARC platform results in these error messages:


rpcbind.c:1061: error: 'val' may be used uninitialized in this function [-Wuninitialized]
rpcbind.c:1084: error: 'val' may be used uninitialized in this function [-Wuninitialized]

These errors don't appear on the x86 platform. Nevertheless, they should be fixed. The file is:


usr/src/cmd/rpcbind/rpcbind.c


Related issues

Is duplicate of illumos gate - Bug #5108: value may be used uninitialized in rpcbind.cClosed2014-08-19

Actions

History

#1

Updated by Marcel Telka about 5 years ago

  • Status changed from New to Closed

This is a duplicate of #5108.

Also available in: Atom PDF