Project

General

Profile

Bug #514

usr/src/lib/Makefile dependicy entry for libnwam misses entry for libbsm

Added by Roland Mainz over 10 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Start date:
2010-12-13
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

While building Illumos today I hit the following build failure:

-- snip --
/home/test001/ksh93/on_build1/core1/usr/src/tools/proto/root_i386-nd/opt/onbld/bin/i386/cw -_cc -o libnwam.so.1 -G -hlibnwam.so.1 -ztext -zdefs -Bdirect  -M../common/mapfile-vers -M/home/test001/ksh93/on_build1/core1/usr/src/common/mapfiles/i386/map.pagealign -M/home/test001/ksh93/on_build1/core1/usr/src/common/mapfiles/i386/map.noexdata pics/libnwam_audit.o  pics/libnwam_backend.o  pics/libnwam_enm.o  pics/libnwam_events.o  pics/libnwam_error.o  pics/libnwam_files.o  pics/libnwam_known_wlan.o  pics/libnwam_loc.o  pics/libnwam_ncp.o  pics/libnwam_object.o  pics/libnwam_util.o  pics/libnwam_values.o  pics/libnwam_wlan.o -L/home/test001/ksh93/on_build1/core1/proto/root_i386/lib -L/home/test001/ksh93/on_build1/core1/proto/root_i386/usr/lib   -lbsm -lc -ldladm -lnsl -lnvpair -lscf -lsecdb -lsocket
+ /opt/SUNWspro/bin/cc -o libnwam.so.1 -G -hlibnwam.so.1 -ztext -zdefs -Bdirect -M../common/mapfile-vers -M/home/test001/ksh93/on_build1/core1/usr/src/common/mapfiles/i386/map.pagealign -M/home/test001/ksh93/on_build1/core1/usr/src/common/mapfiles/i386/map.noexdata pics/libnwam_audit.o pics/libnwam_backend.o pics/libnwam_enm.o pics/libnwam_events.o pics/libnwam_error.o pics/libnwam_files.o pics/libnwam_known_wlan.o pics/libnwam_loc.o pics/libnwam_ncp.o pics/libnwam_object.o pics/libnwam_util.o pics/libnwam_values.o pics/libnwam_wlan.o -L/home/test001/ksh93/on_build1/core1/proto/root_i386/lib -L/home/test001/ksh93/on_build1/core1/proto/root_i386/usr/lib -lbsm -lc -ldladm -lnsl -lnvpair -lscf -lsecdb -lsocket 
Undefined                       first referenced
 symbol                             in file
_enum_attrs                         /lib/libbsm.so
ld: fatal: symbol referencing errors. No output written to libnwam.so.1
*** Error code 1
dmake: Fatal error: Command failed for target `libnwam.so.1'
Current working directory /home/test001/ksh93/on_build1/core1/usr/src/lib/libnwam/i386
*** Error code 1
The following command caused the error:
cd i386; pwd; dmake install
dmake: Fatal error: Command failed for target `i386'
Current working directory /home/test001/ksh93/on_build1/core1/usr/src/lib/libnwam
*** Error code 1
The following command caused the error:
if [ -f libnwam/Makefile  ]; then \\
        cd libnwam; pwd; dmake install; \\
else \\
        true; \\
fi
dmake: Fatal error: Command failed for target `libnwam'
Current working directory /home/test001/ksh93/on_build1/core1/usr/src/lib
*** Error code 1
The following command caused the error:
cd lib; pwd; dmake install
dmake: Fatal error: Command failed for target `lib'
Current working directory /home/test001/ksh93/on_build1/core1/usr/src
-- snip --

basically the problem is that the dependicy entry for libnawm in usr/src/lib/Makefile does not include libbsm ... and if the build system and the tree being build are out-if-sync in some way such an issue causes build failures.


Related issues

Related to illumos gate - Feature #515: RFE: Update library dependicies in usr/src/lib/MakefileClosedRoland Mainz2010-12-13

Actions
#1

Updated by Roland Mainz over 10 years ago

  • Assignee set to Roland Mainz

taking bug myself...

#2

Updated by Yuri Pankov about 8 years ago

  • Difficulty set to Medium
  • Tags set to needs-triage
#3

Updated by Yuri Pankov about 4 years ago

  • Status changed from New to Closed

Should be fixed in #5468.

Also available in: Atom PDF