Bug #5188

SVR4 packaging shouldn't depend on openssl or libwanboot

Added by Peter Tribble about 3 years ago. Updated 6 months ago.

Status:ClosedStart date:2014-09-21
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:-
Target version:-
Difficulty:Medium Tags:needs-triage

Description

SVR4 packaging depends directly on openssl for package signing. There are no known illumos distributions that use this infrastructure; it's just dead code.

SVR4 packaging depends indirectly on openssl via libwanboot for package retrieval over http(s). Whilst potentially useful, using libwanboot for network transport involves an unsupported library of limited functionality. Any modern system would use a much more modern and sophisticated mechanism for downloading packages over the network.

Removing network retrieval and signing would not only simplify the SVR4 packaging code significantly, it would also remove another openssl consumer from illumos-gate.

History

#1 Updated by Electric Monk 6 months ago

  • % Done changed from 0 to 100
  • Status changed from New to Closed

git commit 32991bedc3a6475f1401855c2318ae5b15f8a16b

commit  32991bedc3a6475f1401855c2318ae5b15f8a16b
Author: Peter Tribble <peter.tribble@gmail.com>
Date:   2017-03-29T23:13:24.000Z

    5188 SVR4 packaging shouldn't depend on openssl or libwanboot
    Reviewed by: Igor Kozhukhov <igor@dilos.org>
    Reviewed by: Alexander Eremin <alexander.r.eremin@gmail.com>
    Approved by: Gordon Ross <gordon.w.ross@gmail.com>

Also available in: Atom