Project

General

Profile

Actions

Bug #51

closed

branding regression for boot menu

Added by Garrett D'Amore almost 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Urgent
Category:
-
Start date:
2010-08-17
Due date:
% Done:

0%

Estimated time:
Difficulty:
Tags:
Gerrit CR:

Description

So when using onu, beadm copies over the old solaris.xpm in the grub config. Grub doesn't like this, because the file is removed.

We need to change beadm to search for and use a generic file, call it splash.xpm. It should override the splash configuration with that file name, and then distros can just simply use a hardlink or replace the file without having to touch code.

As a workaround, the grub menu can be explicitly changed to reference /boot/illumos.xpm, or the entry can just be removed.

Actions

Also available in: Atom PDF