Project

General

Profile

Bug #522

text installer - references to the missing zones

Added by Piotr Jasiukajtis over 8 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Caiman (Installer)
Target version:
-
Start date:
2010-12-15
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:

Description

From IRC channel:

< Tenzer|work> Hmm, I tried using the oi_147 text installer image, and it puts out messages such as "devfsadm: build_devlink_list: readlink failed for 
                     /dev/zcons/estibi.openindiana.org/zoneconsole: No such file or directory" and other zones such as hg.oi.o, richlowe.oi.o, pkg.oi.o and dlc.oi.o

It seems it is still an issue for oi_148 text iso.
In my case I tested that within KVM virtual machine:
- 1CPU 64bit 2.5Ghz
- 2GB ram

History

#1

Updated by Albert Lee over 8 years ago

  • Priority changed from Normal to Low
#2

Updated by Piotr Jasiukajtis over 8 years ago

From /var/adm/messages.0 after reboot:

Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/transcode.fastdev01.uk.openindiana.org/zoneconsole: No such 
file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/transcode.fastdev01.uk.openindiana.org/masterconsole: No suc
h file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/alasdair.fastdev01.uk.openindiana.org/masterconsole: No such
 file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/alasdair.fastdev01.uk.openindiana.org/zoneconsole: No such f
ile or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jdsbuild/masterconsole: No such file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jdsbuild/zoneconsole: No such file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/python.fastdev01.uk.openindiana.org/masterconsole: No such f
ile or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/python.fastdev01.uk.openindiana.org/zoneconsole: No such fil
e or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/test01.alasdair.openindiana.org/masterconsole: No such file 
or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/test01.alasdair.openindiana.org/zoneconsole: No such file or
 directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/aszeszo.fastdev01.uk.openindiana.org/masterconsole: No such 
file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/aszeszo.fastdev01.uk.openindiana.org/zoneconsole: No such fi
le or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/trisk.fastdev01.uk.openindiana.org/zoneconsole: No such file
 or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/trisk.fastdev01.uk.openindiana.org/masterconsole: No such fi
le or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jds.fastdev01.uk.openindiana.org/zoneconsole: No such file o
r directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jds.fastdev01.uk.openindiana.org/masterconsole: No such file
 or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/sfw.fastdev01.uk.openindiana.org/masterconsole: No such file
 or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/sfw.fastdev01.uk.openindiana.org/zoneconsole: No such file o
r directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/onnv.fastdev01.uk.openindiana.org/zoneconsole: No such file 
or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/onnv.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/tomww.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/tomww.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/g11n.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Dec 15 16:02:00 openindiana devfsadmd[94]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/g11n.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
#3

Updated by Jeppe Toustrup over 8 years ago

It seems to be related to this bug on the OSOL tracker: https://defect.opensolaris.org/bz/show_bug.cgi?id=10542

#4

Updated by Alasdair Lumsden about 8 years ago

  • Target version set to oi_151
  • Difficulty set to Medium
  • Tags set to needs-triage
#5

Updated by Julian Wiesener about 8 years ago

  • Target version changed from oi_151 to oi_151_stable
#6

Updated by Chris Jordan about 8 years ago

  • Assignee set to OI Caiman
  • Tags deleted (needs-triage)
#7

Updated by Richard PALO almost 8 years ago

I have this as well after a text install OI_148 then image update to oi_151.
seems messy:

Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/trisk.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/trisk.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/python.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/python.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/aszeszo.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/aszeszo.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/test01.alasdair.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/test01.alasdair.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/tomww.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/tomww.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/alasdair.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/alasdair.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/g11n.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/g11n.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/onnv.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/onnv.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jds.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jds.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/sfw.fastdev01.uk.openindiana.org/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/sfw.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jdsbuild/masterconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/jdsbuild/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/transcode.fastdev01.uk.openindiana.org/zoneconsole: No such file or directory
Aug 28 10:39:42 amilo devfsadmd[243]: [ID 317882 daemon.error] build_devlink_list: readlink failed for /dev/zcons/transcode.fastdev01.uk.openindiana.org/masterconsole: No such file or directory

#8

Updated by Ken Mays about 5 years ago

  • Status changed from New to Closed
  • Target version deleted (oi_151_stable)
  • % Done changed from 0 to 100

Didn't reproduce this issue. Issue seems resolved in current release during testing:

http://dlc.openindiana.org/isos/hipster/OI-hipster-text-20140701.iso

Also available in: Atom PDF