Project

General

Profile

Actions

Bug #5269

closed

zpool import slow

Added by Arne Jansen over 7 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
zfs - Zettabyte File System
Start date:
2015-06-04
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

When importing a pool (at boot or with zpool import) with many filesystem, the process can take minutes. It doesn't matter whether the pool has been exported cleanly or uncleanly.
The problem is that each dataset has its own log chain. On import, all datasets have to be checked if there are logs to replay.
The idea is to speed up this process by paralellizing it.


Subtasks 1 (0 open1 closed)

Bug #5981: Deadlock in dmu_objset_find_dpClosed2015-06-04

Actions
Actions

Also available in: Atom PDF