Project

General

Profile

Actions

Bug #5277

closed

Hipster 2014.10 Gnome applications do not start

Added by Michael Huff over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-10-30
Due date:
% Done:

100%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

There seems to be a problem starting certain gnome or GTK applications on Hipster 2014.10. Trying to start either gnome-system-monitor or gparted produces the following errors:

michael@virtualindiana:~$ which gparted
/usr/sbin/gparted
michael@virtualindiana:~$ su
Password:
root@virtualindiana:~# gparted
ld.so.1: gpartedbin: fatal: relocation error: file /usr/sbin/gpartedbin: symbol _ZN3Gtk5Stock7REFRESHE: referenced symbol not found
Killed
root@virtualindiana:~# gparted&
[1] 1652
root@virtualindiana:~# ld.so.1: gpartedbin: fatal: relocation error: file /usr/sbin/gpartedbin: symbol _ZN3Gtk5Stock7REFRESHE: referenced symbol not found

[1]+ Killed gparted
root@virtualindiana:~# gnome-system-monitor
ld.so.1: gnome-system-monitor: fatal: relocation error: file /usr/bin/gnome-system-monitor: symbol _ZTIN3Gio10ThemedIconE: referenced symbol not found
Killed
root@virtualindiana:~#

This is running in a VirtualBox VM, but didn't happen when I installed from the hipster ISO previous to 2014.10 (OI-hipster-gui-20140701.iso ) .

Actions #1

Updated by Alexander Pyhalov over 6 years ago

gparted and gnome-system-monitor both have incorrect dependencies:

gparted:
depend fmri=pkg: fmri=pkg: type=require-any
depend fmri=pkg: fmri=pkg: type=require-any
depend fmri=pkg: fmri=pkg: type=require-any
depend fmri=pkg: fmri=pkg: type=require-any

gnome-system-monitor:
depend fmri=pkg: fmri=pkg: type=require-any
depend fmri=pkg: fmri=pkg: type=require-any
depend fmri=pkg: fmri=pkg: type=require-any

in both cases these should be require dependencies on /g++/ alternatives.

As fast workaround, please, install missing packages.

Actions #2

Updated by Alexander Pyhalov over 6 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 100

We have dropped support for Studio-compiled libraries. All Hipster-provided libraries are considered g++-compatible and are delivered in /usr . Studio-compiled C++ libraries, provided earlier by OI, are available here: http://dlc.openindiana.org/c++-libs/ .

Now we don't have a possibility of getting similar errors in the future.

Actions #3

Updated by Ken Mays over 6 years ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF