Project

General

Profile

Actions

Feature #5390

closed

Support for HP Smart Array P440ar

Added by Jernej P almost 7 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2014-12-04
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

HP DL380p Gen9 servers come with HP Smart Array P440ar HBA, which are currently unsupported with cpqary3 driver.

We have compiled a simple patch for current cpqary3 driver, based on linux hpsa driver, however we haven't tested it yet, while we are having some issues compiling new OmniOS images.

If there is someone with deeper knowledge of cpqary3 driver, this patch might speed up the integration of new HP Gen9 HBAs into Illumos kernel.


Files

patch-HP-P440ar.patch (1.25 KB) patch-HP-P440ar.patch patch of cpqary based on OmniOS code Jernej P, 2014-12-04 03:52 PM

Related issues

Is duplicate of illumos gate - Feature #6113: cpqary3: add support for hp gen9 smart array controllersClosedRobert Mustacchi2015-08-11

Actions
Actions #1

Updated by Marcel Telka almost 4 years ago

  • Is duplicate of Feature #6113: cpqary3: add support for hp gen9 smart array controllers added
Actions #2

Updated by Marcel Telka almost 4 years ago

  • Status changed from New to Closed

The support for HP Smart Array P440ar was added by #6113. Closing as duplicate.

Actions

Also available in: Atom PDF