Project

General

Profile

Bug #544

BGE driver hangs system after update to oi_148

Added by Hernán Saltiel over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
OS/Net (Kernel and Userland)
Target version:
Start date:
2010-12-17
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage

Description

Hi!
After updating oi_147 to oi_148, the system hangs when booting, immediately after the message:
PCI-device: pci14e4,969c@3, bge0
bge0 is /pci@0,0/pci1106,337a@13,1/pci14e4,969c@3
To obtain this messages I modified the boot menu adding "-v" at the end of the "kernel" line, deleting "console=graphics", and deleting the splash image line.
How can I debug this driver at boot time?
Thanks, and best regards,

HeCSa.


Related issues

Related to illumos gate - Feature #390: bge driver need to support Broadcom BCM5784M chipsetIn Progress2010-11-01

Actions
Related to illumos gate - Feature #3446: Update bge to support missing 57xx/577xx devicesClosed2015-04-06

Actions
Has duplicate OpenIndiana Distribution - Bug #551: USB image fails during boot on Dell Precision M6300Resolved2010-12-18

Actions

History

#1

Updated by Hernán Saltiel over 8 years ago

Sorry for the mistake, it seems that the problem is not the bge0 driver...this time I booted adding "-m verbose", "-v" and deleting "console=graphics", and the messages are pointing to a ZFS trouble:
[ system/filesystem/root:default starting (root file system mount) ]
pseudo-device: zfs0
zfs0 is /pseudo/zfs0
After that last line, the system hangs.
Best regards,

HeCSa.

#2

Updated by Albert Lee over 8 years ago

I won't rule out bge entirely as there were (previously tested) changes to the driver in oi_148. Can you try booting with -B disable-bge=true (if -B is already present, -B <existing args>,disable-bge=true)?

#3

Updated by Albert Lee over 8 years ago

  • Target version changed from oi_148 to oi_151

Taking, as I am responsible for the bge changes.

#4

Updated by Albert Lee over 8 years ago

  • Assignee set to Albert Lee
#5

Updated by dennis sexton over 8 years ago

  • Assignee deleted (Albert Lee)
  • Target version changed from oi_151 to oi_148

I have a Dell 610 laptop that also has a broadcom (bge) chip for its network. I had the same problem
as the original poster. On bootup of oi_148 I would get a freeze after a few minutes of the zylon bouncey
bouncey. I added Albert's suggestion to the $KERNEL line (disable-bge=true). The system booted and I can login
to the gui. Of course now I have no bge interface :-( This laptop does have an iwi interface and that works.
It would be helpful to have the gigabit interface back obviously. Let me know if there is anything
I can test or you would like more info about the laptop. ()

#6

Updated by dennis sexton over 8 years ago

I was given some binaries to test by illumos login Triskelios.
They worked. They came in a tarball labeled bge-oldintr.tar.bz2 but alas I forget the download url.

#7

Updated by Albert Lee over 8 years ago

  • Assignee set to Albert Lee
  • Target version changed from oi_148 to oi_151

The workaround is http://pkgdev.openindiana.org/~trisk/bge-oldintr.tar.bz2 - which omits the interrupt acknowledgement changes in #390. Copy debug32/bge to /kernel/drv/bge and debug64/bge to /kernel/drv/amd64/bge.

#8

Updated by Albert Lee over 8 years ago

  • Status changed from New to Resolved

This was fixed in a oi_148 update.

#9

Updated by Albert Lee about 8 years ago

  • Difficulty set to Medium
  • Tags set to needs-triage

If you're unable to boot a system with a Broadcom Ethernet card, you can disable the bge driver temporarily as a workaround. At GRUB menu, press 'e' to edit the default menu entry. Highlight the kernel$ line, press 'e' to edit, and append -B disable-bge=true to the end of the line. Press 'Enter', then 'b' to boot.

Once the system boots (and installs, if you haven't installed it yet), sudo pkg image-update to install the fixed driver.

If you cannot update oi_148 because you need bge for networking, download this patch on another computer:

http://trisk.deadgerbil.com/bge-544.tar.bz2
To install:

cd /kernel/drv
tar xfj </path/to>bge-544.tar.bz2
bootadm update-archive
reboot

#10

Updated by Albert Lee about 8 years ago

For clarification: At the GRUB menu, press 'e' to edit, highlight kernel$, press 'e' to edit, append -B disable-bge=true after the end. This disables the driver temporarily, so you can replace it with the fixed one by running pkg image-update or manually installing the patch above.

Also available in: Atom PDF