Project

General

Profile

Actions

Bug #5448

closed

sed core dumps on y command

Added by Alexander Pyhalov almost 7 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Start date:
2014-12-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Medium
Tags:
needs-triage
Gerrit CR:

Description

$ echo 'test' | /usr/bin/sed -e y,a,A,
Segmentation Fault (core dumped)

$ uname -a
SunOS buildzone.oi-build.r61.net 5.11 illumos-a74909f i86pc i386 i86pc Solaris

(illumos-gate built 2014.12.16)

$ pfexec pstack /var/cores/sed.7351
core '/var/cores/sed.7351' of 7351: /usr/bin/sed -e y,a,A,
feeb6979 _UTF8_mbsnrtowcs (0, 804748c, ffffffff, 0, 0, 3) + 2d
feea8f8d mbsrtowcs_l (0, 804748c, 0, 0, fee01a00, 8067d66) + 35
feea8fd1 mbsrtowcs (0, 804748c, 0, 0, 0, 0) + 42
08053f2e compile_tr (8067d61, 806a67c, 0, fee10048, fefcac27, fee10048) + 132
0805493c compile_stream (806a668, 8047da0, 8056ad2, 80563a0, 0, 806a260) + 7b8
08054af3 compile (0, 3, 100, 0, 0, feffb0a4) + 10
080531b5 main (8047d5c, fef72668, 8047d94, 805251b, 3, 8047da0) + 1a8
0805251b _start (3, 8047e64, 8047e71, 8047e74, 0, 8047e7b) + 83


Related issues

Is duplicate of illumos gate - Bug #5158: sed dumps core in new multibyte codeClosed2014-09-12

Actions
Actions #1

Updated by Yuri Pankov almost 7 years ago

Duplicates #5158.

Actions #2

Updated by Yuri Pankov almost 7 years ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF